Thread: 272's
View Single Post
Old 04-12-2006, 12:27 PM   #9
LatentWagen
Scooby Guru
 
Member#: 50315
Join Date: Dec 2003
Chapter/Region: Tri-State
Location: New York
Vehicle:
0508 Saabaru & specB
Stage: Maintenance

Default

Quote:
Originally Posted by Element Tuning
So far so good with the 272 cams I have. We installed Kelford AVCS 272, 10.26 mm lift on both the intake and exhaust side into a 2.5 built block with stock STI heads. Vacuum at idle is poor at only 15 in/hg as compared to stock cams at 20 in/hg.

Since we run the Element Hydra EMS I have lots of control over fueling, timing, ISC settings, etc and once adjusted to compensate for the low vacuum the car idles completely steady at 1000 rpm. I can hear a little "lope" but it doesn't move the needle at all.

Power above 5K rpm is of another world! With everything else constant, at 20 psi my fuel map leaned out from about 11.8 AFR to 13.5 AFR. WTH, I thought, my WB must be bad. Everything checked out, egts, etc all were in line so I just added fuel into the map to restore my previous AFR.

I predict this is car is going to have the highest pump gas power number anyone has seen here on Nasioc. The fuel map does not lie and I have already tuned a car to 490 whp on pump gas so I know what I'm looking at!

Thanks,
Phil
www.elementtuning.com
ill be glad to see some dyno results!! its about time we had more people running cams - every other camp does it... granted the install is a *little* harder on our cars.
what turbo are you running with that setup? and what's your redline?
* Registered users of the site do not see these ads.
LatentWagen is offline   Reply With Quote