View Single Post
Old 05-23-2006, 10:06 AM   #6
AaronWRX
Scooby Specialist
 
Member#: 7194
Join Date: Jun 2001
Chapter/Region: MAIC
Location: NoVa
Vehicle:
2011 997.2 Turbo
Black

Default

Wirelessly posted (xv6700 EVDO: Mozilla/4.0 (compatible; MSIE 4.01; Windows CE; PPC; 240x320))

Quote:
Originally Posted by bcblues
I have carefully checked the factory hoses, and there is no restrictor. These are brand new factory hoses that came with my new turbo from Subaru.

I can boost up to 17-18 psi in higher gears with a long pull. But in 1st and 2nd, I rarely hit 14 psi, even on hard pulls.

I am running the ABC, and have unscrewed the allen screw until it is backed out of the body of the ABC about half way. I did not count turns, but it must be about 15. When screwed in and backed off 3 turns, I run wastegate pressures.

UTEC dashboard confirms that the map selector switch is actually running my selected map (both switch and map are reading the same, correct number).

Assuming that somehow Subaru provided my local dealer with a new stock STi turbo that did not come with the restrictor, how do I go about getting one? I have heard that they are no longer available.
I switcthed to a perrin ebcs and loved it. knowing what i know now, if i were in shoes i wouldn't bother with troublesooting this further and would switch to a perrin ebcs or GM solenoid and enjoy consistent boost with the lines you already have.
* Registered users of the site do not see these ads.
AaronWRX is offline   Reply With Quote