View Single Post
Old 10-23-2008, 11:38 AM   #1
hail2theTheif
Scooby Specialist
 
Member#: 42548
Join Date: Aug 2003
Chapter/Region: BAIC
Location: Redwood City, CA
Vehicle:
2015 Base STi
Black (CBS)

Default possible bad fuel pump?

Car is a ej20g with sti 2.5 shortblock, yellowtop inj, wrx fuel pump, pfc, new age coil upgrade.

So while driving home on a road trip this weekend my car started randomly juttering/jerking while cruising at around 85. Pulled over when it became bad and initially thought ignition. Took off all the coils and double checked the wiring and cleaned up the wires a bit. Car started up and I continued to drive. Made it back home but the whole time occasionally the car would do the jutter.Felt like the car just lost power for a split second.

Yesterday while driving the car all the sudden severely started juttering and loosing power in and out and then eventually straight up died. Thought I was out of fuel. Filled her up and still nothing. Car cranks but doesn't turn over. After trying to start it a few more times the car started and idled for 10 min then would die.

Took the fuel pump out to make sure it was working. Could hear it spinning and pumped fuel out of the lines. BUT when just trying to turn over the car no luck. BUT if i prime the car (turn the key from off to on) a good 5-10 times the car will start right up run great and then die after 10 min.

So I'm guessing it's running off the fuel it was primed with then dying after it burns it? Or the pump can pump enough into the lines but can't hold pressure?

Really need some ideas here. When the car does start it runs very well.
* Registered users of the site do not see these ads.
hail2theTheif is offline   Reply With Quote