View Single Post
Old 04-05-2009, 11:18 AM   #120
AshJWilliams
Scooby Newbie
 
Member#: 189781
Join Date: Sep 2008
Location: OH
Vehicle:
2010 Tacoma
Black

Default

Quote:
Originally Posted by tom bourque View Post
ok...this is the thread i have been looking for! I bought a 09 wrx in October of last year and this chistmas i had too get the turbo replaced because oil was not getting to the turbo. Instead the oil was sprayed all over the engine compartment, causing the burn out of the turbo. Before this happened i had that juddering sound under the hood. Just this past week that same sound happened again, the next time i went too turn the car on it was dead. Subaru had the car brought in too the nearest dealership to give it a look over. Now i am in my second week of waiting for a new turbo and a new engine! This is all covered by warranty, but come on this is not what i expected of a Japanese product let a loan a subaru! I have done my home work for the last eight years on these cars and finally decided too get one... I guess you could say that i am a proud owner of a 35,000 dollar NIGHTMARE!
I wouldn't be so sure of that Tea cups. Besides we have deemed this thread the 09 WRX engine failure thread; this guy needed a replacement engine at some point so I take it his previous engine failed.

Tom it seems like others have had the same concerns as you about the VIN. Just provide your VIN in the following format (based upon my VIN): instead of 500277 do 500XXX or 5002XX.
* Registered users of the site do not see these ads.
AshJWilliams is offline   Reply With Quote