View Single Post
Old 02-24-2001, 08:40 AM   #1
Revision
Scooby Guru
 
Member#: 242
Join Date: Sep 1999
Chapter/Region: MWSOC
Location: Carol Stream, IL USA
Vehicle:
MY05 PSM GGA !STOCK
MY99 RS-RIP / MY95 MX-5

Post Rallispec Intake (review 14k miles)

Well, after @14k miles and 6 months I figured it was time to clean the Rallispec intake. For reference, I have a MY99 with the Apexi SAFC and Stromung midpipe. I have experience NO check engine lights or other failures of any kind. The spare MAF is for reference only. The spark plugs all came out clean with the exception of #4 which is part of another post.


Here we have a shot of the Pipercross cone filter & MAF along side a New In/Out of Box MAF.
<IMG SRC="http://albums.photopoint.com/j/View?u=1155221&a=11755957&p=41856165&Sequence=0&Sc ale=320x200" border=0>

Here is a comparision of the insides of the new and used MAFs. Note there was no dirt to be found inside the MAF. There was some dust on wire mesh, which was neglegible.
<IMG SRC="http://albums.photopoint.com/j/View?u=1155221&a=11755957&p=41856172&Sequence=0" border=0>

Washing the foam filter element with Simple Green and luke warm water.
<IMG SRC="http://albums.photopoint.com/j/View?u=1155221&a=11755957&p=41856182&Sequence=0&Sc ale=320x200" border=0>

A lot of dirt came out of the filter which took repeated washings before the water finally came clean.
<IMG SRC="http://albums.photopoint.com/j/View?u=1155221&a=11755957&p=41856184&Sequence=0&Sc ale=320x200" border=0>

All shiny and new. I let this air dry and didn't oil as per RalliSpec's specs.
<IMG SRC="http://albums.photopoint.com/j/View?u=1155221&a=11755957&p=41856191&Sequence=0&Sc ale=320x200" border=0>

Here is the tube side of the intake. There were some minor scratches on the inside which were noted, but no dirt whatsoever. Even after passing several shop towels through the tube, nothing was found.
<IMG SRC="http://albums.photopoint.com/j/View?u=1155221&a=11755957&p=41856236&Sequence=0" border=0>

Here is the installed intake in a new direction. I think I may have just scared some people.
<IMG SRC="http://albums.photopoint.com/j/View?u=1155221&a=11755957&p=41856239&Sequence=0" border=0>


For some reason, this mounting position just doesn't seem to work. Even though it seems that the intake could be fitted through the hood scoop.
<IMG SRC="http://albums.photopoint.com/j/View?u=1155221&a=11755957&p=41856242&Sequence=0" border=0>

So far, I am very happy with the intake. No dirt has come through even with the dusty summer and the salty winter here in Chicago. Maintainance is a snap. Power delivery remains good and the sound quality, though sometimes loud at WOT, is worth it.
* Registered users of the site do not see these ads.
Revision is offline   Reply With Quote