View Single Post
Old 06-28-2009, 11:29 PM   #13
Henry H
Scooby Newbie
 
Member#: 184330
Join Date: Jul 2008
Location: Southern California
Vehicle:
2008 Impreza 2.5i
Dark Grey Metallic

Default

Express kit:
I would have your installer to just use the 5901 alarm rather than the factory alarm. But if there was an "express kit" that only utilizes the OEM alarm, I guess you have no choice. There should be two wires that arm and disarm the factory alarm. I have no idea what wires are interfaced with the factory alarm, but its obviously not wired correctly or you have a defective alarm.

Daddyb makes a good point about the factory alarm; that has to be disabled when the autostart initiates. I had installed my own 5701 (shouldn't be much different than a 5901 in this case) and just disabled the factory alarm completely

Domelight door trigger:
I am not sure if the domelight can be used. The domelight dims so it still gets some voltage when you close the doors. I know the alarm system needs a full 12v as a trigger, but I just did a little extra work and used the 4 door sense wires in the DKP and diode isolated them all.

Your autostart problem:
If is indeed your factory alarm, then your installer did not wire the factory disarm wire correctly. If autostarting triggers the viper alarm then it is defective. The integrated autostart automatically disables (not disarm) auxilary sensors as well as integrated triggers (like shock sensors or starting sensor etc). Regardless, take it back and give em hell.

Ysidro
Ysidro, if you are right about no wire for the viper system to disarm the factory security then you definitely need an aftermarket alarm system (your 5901) to be triggered. Also, I think all the 08's have an immobilizer chip, but I don't think DEI (Viper's momma) makes a bypass for the Subie's, or at least NTIKO.
* Registered users of the site do not see these ads.

Last edited by Henry H; 06-28-2009 at 11:36 PM.
Henry H is offline   Reply With Quote