View Single Post
Old 01-19-2011, 02:47 AM   #69
subaru92584
Scooby Newbie
 
Member#: 253086
Join Date: Jul 2010
Default

Quote:
Originally Posted by Subirex09
Damnit...the pulsation is still there : /.

The motor and tranny mounts still made a huge positive difference and the driving experience is much more enjoyable but I really was hoping it was a remedy as well.


The clutch pedal felt loose right before it happened. Pumping it
the pedal feel and stops the pulsation. I wasn't even doing hard pulls when it happened this time, sucks.


Are you guys talking about a high pitch squeling noise, similar to a loose belt. Also if you just barely press down on the clutch petal right before the clutch engages it goes away immediately. It's from a slight vibration where the clutch pin sits into the clutch fork and over time it will where a hole right thru the clutch fork. The vibration sound started on my car at about 10 k miles. I took it into the dealership two different times and both times they replaced the throw out bearing and it never fixed my problem. After that I just kept driving my car and I figured sooner or later it's going to get so bad that something is going to break and then I would finally find out where the damn noise came from.
If u have this sound, vibration problem I suggest taking it into the dealership and have them replace the clutch fork until the sound stops completely. Because I know that not every single Subaru makes that noise.
* Registered users of the site do not see these ads.
subaru92584 is offline   Reply With Quote