View Single Post
Old 04-05-2011, 01:14 PM   #3
J. Steinbeck
Scooby Specialist
 
Member#: 140575
Join Date: Feb 2007
Location: Hotlanta, GA
Vehicle:
2007 Magnum SRT-8

Default

I've used that kit before, and it was fine. I think I ordered it through OAKOS, but you are looking at the same part number for a little bit less. Come to think of it, I may have ordered one through Rock Auto as well. Whatever... my memory is horrible.

IIRC, the waterpump that comes with those kits is not OEM- you can instantly see the difference in the blade design when you compare the kit and OEM pumps side by side. That being said, I don't think it matters, as the pumps that I've used from those kits have worked perfectly fine.

I also think I may recall this kit not having one of the pulleys... possibly the small one closest to the driver's side intake cam. You might want to verify that, as I may be thinking of another kit that had that issue. Even if it doesn't include a pulley you can order the missing one from the dealer or from O' Reilly's (for some reason I have been able to get Subaru idlers through them without issue, unlike Advance or Autozone) and still end up with a good deal for the overall price.

Some people like to upgrade to those kevlar belts, but really, unless you are driving the absolute dog**** out of the car the OEM Gates belt used in this kit will be fine... if you are at 100,000 miles it may very well outlast your motor.
* Registered users of the site do not see these ads.
J. Steinbeck is offline   Reply With Quote