View Single Post
Old 08-10-2011, 11:04 PM   #100
wrxphantom
Scooby Specialist
 
Member#: 128643
Join Date: Oct 2006
Chapter/Region: Tri-State
Location: Brooklyn
Vehicle:
2013 STI Sedan
White

Default

Quote:
Originally Posted by turboman38
I installed my prosport gauges last night. Couple things I ran into.

My oil pressure gauge was too big (too deep) to fit into either side. I actually cut a portion of the gauge off with a hack saw in the back. If you look at how the pods are shaped, the rear of the pod is cut at an angle. This did not allow my gauge to be pushed the hole way in.

I also had a sandwich adapter for the oil pressure gauge. This does not work on a 2011 WRX. The sending unit ProSport sent with the kit was too large in diameter and hit the block when I tried to install it.

When I wired the Prosport gauges I put the constant 12 volt wires (red wires on gauges) in IG2. Maybe I had it wired wrong but when I put them in the Door Lock fuse port the lights in the gauges were always on. I also put the orange illumination wires in fuse port ILM. I was not worried about the sweep. One thing I did notice was my gauges got brighter when you turned the lights on which is the way it's supposed to work but when you turn the lights off they did not go back to the dimmer setting.

Anybody else had these issues with the ProSport gauges?
Which Prosport oil pressure gauge do you have that doesn't fit? I know the new white needle gauges fit with plenty of room as well as the Halo and premium gauges.

If I have to guess it is the performance gauge series which has the old stepper motors making the Gauges longer then 2". Please clarify.
* Registered users of the site do not see these ads.
wrxphantom is offline   Reply With Quote