View Single Post
Old 08-25-2011, 05:06 PM   #53
CTSparky
Scooby Specialist
 
Member#: 282204
Join Date: May 2011
Chapter/Region: NESIC
Location: Northeast CT
Vehicle:
2011 5 Door STi
Plasma Blue Pearl

Default

Quote:
Originally Posted by jockeygolfs View Post
Time has come! Engine is dead. Even on a conservative map. i was running at 21.5 PSI max. My mechanic says 19 is the max on OEM pistons. Currently waiting to be towed. I'm in the middle of nowhere. Just south of the city of Okeechobee in FL. Car was sounding awesome and then sputtering. The car was making weird sounds like playing cards in bike spokes.

So I pulled off the road and called Gustavo at TAV racing. He told me to check the oil. It is all gone. The oil light would come on when I pumped the clutch but then disappear. The oil temp reached 240. The car is going to be towed to the dealership but I have a feeling I will be screwed on the warranty, obviously.

The wife is going to go ballistic when she finds out warranty is gone lol.

Already have a quote to ship the car down to TAV. $175. Not bad. Build motor will be $400 by Bertune. $1500 to install. Hopefully no hang ups and we should be good. I am still missing a timing belt, head studs, gaskets and bearings though so that should all add up to about $800. So roughly $3000 total.
I'm sorry to hear this. I hope you and your wife work things out.

good luck in the engine rebuild. At least now you can built the bottom end to handle the power.
* Registered users of the site do not see these ads.
CTSparky is offline   Reply With Quote