View Single Post
Old 01-25-2012, 08:02 AM   #42
Overland04
Scooby Specialist
 
Member#: 293311
Join Date: Sep 2011
Chapter/Region: NESIC
Location: Coast of Maine
Vehicle:
2011 WRX Limited
Satin White Pearl

Default

Quote:
Originally Posted by cliff_11WRX
How's the prosport gauges doing? I've read a couple threads on here about the oil pressure gauge failing and the sender failing also. Your DIY threads are absolutely amazing and the pictures are great! About to order the prosport gauges but after reading some of the thread of it failing I'm a little worried.
The gauges are doing very well. If there is something to say about them it would be:
They are a little noisy, upon startup when they do the opening ceremony you hear the motors winding and the same when you shut them down.
The oil pressure seems to be fine. It does jump around a bit but it measures accurately.
Lastly is, they are an inexpensive gauge compared to the Defi so if you tap the housings, they sound and feel inexpensive. I'm using the pod, cup and visor so I have the full "plastic" package going.

Honestly, If I had to do it again I would still buy them. I'm telling you only my complaints but for all three gauges to be around $300, I really think they are good gauges and a great deal. If I had the extra $, yes I would buy the Defi but they are crazy expensive and for what I use them for, they are perfect!!

Hope that helps!!
* Registered users of the site do not see these ads.
Overland04 is offline   Reply With Quote