View Single Post
Old 03-23-2012, 01:35 AM   #222
Scooby Newbie
Member#: 310047
Join Date: Feb 2012
Chapter/Region: NWIC
Location: Seattle
2012 Sport Limited


Originally Posted by thom52 View Post
New POSSIBLE "fix" to try for those suffering from obscenely low gas mileage. (BELOW 20 overall for us).

The dealer hooked up our car for a diagnostic and sent us away with "no codes= no problem", BUT the car has been getting significantly better mileage since. Including a "calibrated" mixed freeway-city errand running.

Time will tell if this is a temporary "glitch" or if maybe hooking it up cleared some bad setting or something.

Car runs smoother and no hard starts since. Its only been a couple days. Time will tell, but we have some hope now.

Sooooo..... maybe try getting the dealer to run a diagnostic? MAYBE try shutting down the computer (unplugging the battery) and hooking it back up again to reset it. Just a wild guess, but might be worth a shot. (no warranties expressed or implied)
Interesting, this sort of coincides with the scattered reports that folks mpg improved right after the first oil change during which time the dealer service center certainly hooks up the diagnostic system.

However the dealer probably runs the same tests after they get the car off the delivery truck though before they sell it.

Glad your mpg is better though! Mine is still about 22.5 overall, largely city driving in hilly/congested Seattle, mostly shortish trips.
* Registered users of the site do not see these ads.
seaflipper is offline   Reply With Quote