View Single Post
Old 07-23-2012, 11:19 AM   #392
Giuliana.Heather
Scooby Newbie
 
Member#: 326980
Join Date: Jul 2012
Chapter/Region: MWSOC
Location: junction city, kansas
Vehicle:
05 legacy gt
pearl black

Default brought it to the shop :-(

My 05 legacy gt was in a front end accident in May, got it repaired got it back in June and I drove it 550 miles to Denver. On my way I heard a POP I thought it was a tire blowing on a camper passing by because the car showed absolutely no indication something happened. After driving around Denver for a couple days the check engine light and cruise control light came on. Brought it for a diagnostic. Misfire on cylinder 1 and two compression tests saying cylinder 1 lost 50 psi of pressure. I took it back to a collision shop and they said all my coolant lines are leaking my valve gasket covers are leaking and apparently my turbo coolant hose is too small? Not my doing. Oil cooler is leaking. My main concern is the engine. It's got 102,000 miles on it and at 94000 my complete vehicle inspection says my valve gasket covers were good. What caused this? Insurance is trying to say preventive maintenance but I take great care of my car pay $30 just to have everything inspected every time I bring it in. Please help :-( oh and they cleared the codes gave me no conclusion to what's wrong with the car. I drove it 550 miles back to junction city ks. Check engine light came back on when I stopped for gas.
* Registered users of the site do not see these ads.
Giuliana.Heather is offline   Reply With Quote