View Single Post
Old 08-08-2012, 11:45 PM   #5
nasiocjunkie
Scooby Specialist
 
Member#: 80864
Join Date: Feb 2005
Chapter/Region: AKIC
Location: Anchorage, Alaska
Vehicle:
I'll have the tuna.
No crust.

Default

Reason for the compression test:

The OBS threw a P0303 code during the weekend. Pulled the spark plug and cleaned with a wire brush. Tested again but car still had a rough idle and felt like it wanted to stall when put into drive or reverse. Since then these:

New plugs and wires
New coil pack
New coolant temp sensor
Cleaned maf but still want to know what the frequency readings are
Checked all hoses and all are good
New PCV valve
Cleaned throttle body and iac
New front 02 sensor
Checked all connectors under hood scoop and all were dry
Reset ecu

Started car after all that and rough idle went away but now it's running really sluggish with a bad throttle lag. I drove around the block hoping the the OBS would throw a cel but nothing came up. Next I want to check maf sensor, fuel filter/injectors/pump/hoses, timing, camshaft position sensor, compression ratio, and cat converters. I'm hoping I don't need to do a tear down but we'll see.

After two days of investigating:

Found auto-start wire melted on my egr pipe which blue a fuse and ruined my coilpack. Repaired wire and tucked away from pipe, new fuse, and new coilpack. Car runs even better with everything else done to it! Compression test readings cyl 1 - 220, cyl 2 - 210, cyl 3 - 210, and cyl 4 - 205. Will Seafoam soon and retest compression to see if those readings will go down. Yay for no more hesitation! Also maf sensor checked out. Brought my car to a garage and had them scan it and it passed. After finding and fixing problem the only other item I'd like to check/change is the fuel system. Other than that I'm pretty happy with everything that was done to it so far...and more to come!
* Registered users of the site do not see these ads.
nasiocjunkie is offline   Reply With Quote