View Single Post
Old 09-08-2012, 10:39 PM   #30
UncleSchnitty
Scooby Newbie
 
Member#: 298703
Join Date: Oct 2011
Chapter/Region: Tri-State
Location: Philadelphia PA
Vehicle:
2004 Wrx
Blue

Default

My problem with taking it to the place that installed it is that I had to have it installed in maryland and I live in PA(I was on vacation when my original blew after only owning the car for 4 weeks, I know Im lucky) When I took it to a subaru dealership up here they were hesitant to look at it and said if they do and even if its defective install or item they would make me pay since it wasn't done at that particular dealership. I called up SOA and they said they would authorize the shop to look at it but if they didn't find anything I had to pay the $250 diag. Guess what? They didnt find anything and I had to pay.
Ok so heres my problem with the dealerships:
1. It took the first place a week and a half to put on the turbo and when I got the car back the one side of the intercooler was bolted under the bracket and was pinching the throttle body hose.
2. after the shop up here "looked at it" I installed a factory heatshield a few weeks later (that the first dealership said was unnecessary)and noticed the top two bolts that hold the factory heatshield on had no nut on the other side!
3. neither dealership could tell me the boost levels they were getting when they "tested"


At this point I wana try to stay away from dealerships because im pretty sure they think the radiator is on top of my engine (:-) I kid)
* Registered users of the site do not see these ads.
UncleSchnitty is offline   Reply With Quote