View Single Post
Old 09-20-2012, 07:10 PM   #1
redrex2002
Scooby Specialist
 
Member#: 118915
Join Date: Jun 2006
Chapter/Region: Tri-State
Location: Rochester, NY
Vehicle:
2002 wrx
srp

Default misfire code help please

hey guys, where do i begin...
i own 2002 wrx that i bought in 2005 with 42k miles on the clock. it now has 202k miles and i just recently gave it a fresh coat of paint. while doing the paint job and waiting for my mechanic buddy to put in some power steering lines the car sat around for about a month, only being started briefly to move it around the parking lot and the shop. i got my car back last night and started driving it around town running errands. i was able to drive maybe 5 or 6 miles before my cel started flashing at me. so i scanned the code and it was a p0304. so i had the car towed back to the shop today and i swapped out the coilpacks and the spark plug.

when i go to start the car and see if all is well it starts perfectly and runs normal for the first 30 or 45 seconds, then the motor starts to shake and run rough. then the check engine light begins to flash again and i shut it off.

i am at a loss for what to do next and rather frustrated. over this last summer i have put 800 dollars of paint and clear, as well as a starter (x4), cps sensor (x2), battery, spark plugs (x4), and one coilpack for cyl. #3 all to try and pix a p0335 cel that as still to this day eluded capture. i have all but run out of money at this moment, right now me and my wife are sharing one car which is getting almost impossible now that school has started.

please help me save my car, if anyone has any ideas as far as what i should look into next i would really appreciate it.

and now banna's
* Registered users of the site do not see these ads.
redrex2002 is online now   Reply With Quote