View Single Post
Old 09-26-2012, 11:14 PM   #480
bugeyetex
Scooby Specialist
 
Member#: 283815
Join Date: May 2011
Chapter/Region: TXIC
Location: San Antonio
Vehicle:
2003 psm wrx wagon
Built Fuji Tough

Default

I will have some good pics soon. I started taking the motor out of a Baja today with a nasty lower end noise. I also have an Envoy back that we did valve job on a couple of months ago, 9 out of the 14 head bolts broke off in the block.

This time, they found a giant puddle of coolant under it..... topped it off and headed out to Dallas... I started with a waterpump since that threw the belt off and was leaking like crazy. It was bad enough that when you held it sideways, the ball bearings fell out the front. (odd job, it had an electric fan clutch- why not an electric fan? GM works in mysterious ways) Didn't get a pic before it disapeared though- my apologies.

As I was topping off the coolant, it starting exploding out of the top of the radiator. Suspecting a blown headgasket, I hooked up my pressure tester to the radiator and started the motor. It pegged the gauge at 30 psi the second it kicked over. I then pulled off the cap to relieve the pressure so I could move it to the back and and work on something else while the customer decided what to do. Once it has parked, I noticed that water was dripping out the side of the motor where the head meets the block.

Pics will follow soon...
* Registered users of the site do not see these ads.
bugeyetex is offline   Reply With Quote