View Single Post
Old 10-02-2012, 02:54 AM   #1
2man
Scooby Newbie
 
Member#: 240009
Join Date: Mar 2010
Chapter/Region: TXIC
Location: Denton, Texas
Vehicle:
2005 WRX STi
crystal metallic grey

Default Smokes Really Bad!?

My car is burning oil really bad. At idle it would be a constant smoke, but when I give it some throttle, it's like a house caught on fire! SO ... after awhile of poking around. I saw that oil is coming out of the compressor side of the turbo. I cleaned the intercooler, hoses, and lines and put everything back together to run it (SO I could park it outside.) It idled fine and there were barely any smoke at idle for a few minutes, until I decided to give it some throttle again and again it raged up the blueish tinted smoke.

The turbo was taken out and brought to the guys at Majestic turbos to ideally get rebuilt. When I got there, the guy behind the counter had some time and consulted with me. Outstanding guy he was because he actually helped diagnosed the turbo and asked what happened. He said the turbo seems to have no shaft play and spins freely but also told me to check my engine first to see if there were any problems with it. But if I insist he could have just taken the turbo and put in a work order for a rebuild.

So I thanked him and left with my turbo in hand. I have not done anything yet so far. I'm looking to get some ideas and possibly where to look. He also said there was a possibility that the oil could come back up the turbo return line and leak out. If anyone has any ideas or knows where or what I should do next, I'd appreciate it a lot!
* Registered users of the site do not see these ads.
2man is offline   Reply With Quote