View Single Post
Old 10-10-2012, 09:09 PM   #1
jonesy08
Scooby Newbie
 
Member#: 333611
Join Date: Sep 2012
Location: spanaway, wa
Vehicle:
2003 impreza wrx
white

Thumbs down clutch, burning oil and vibration

I just purchased a 2003 wrx with 120,000 miles on it about 2 weeks ago. It had been hit in the front left and wasn't fixed(dealership was just going to wholesale it to a lot, but tried selling it themselves first). For this reason I picked it up for about 3000 under KBB value, figured "fender, bumper and headlight?" not a problem. Have replaced all of that and am now fiding more things, which are going to prove more expensive, I know. Today I noticed it was burning quite a bit of oil when I was in boost in 3rd gear getting on the highway. I don't have a boost gauge(doing that saturday) so I don't know exactly when it started happening in the boost range. Haven't checked turbo for oil coming out of it tonight to rule that it needs that, but thats what I'm thinking. Any other ideas? Are valve seats something I should be thinking about? This is my DD and I can't afford to rip it out to rebuild the heads at this current moment.

Also noticed a whining sound while slowing down, most noticeable in second gear, that goes away when I push the clutch in. The clutch does not slip though.

And last, and hopefully least, while cruising down the road the car seems to have a slight "bounce" to it, idk how else to describe it.

Any and all help on these is greatly appreciated, haven't had time to get to do any troubleshooting on any of this yet.
* Registered users of the site do not see these ads.
jonesy08 is offline   Reply With Quote