View Single Post
Old 10-28-2012, 05:29 PM   #36
kapp_badbloodz
Scooby Newbie
 
Member#: 203327
Join Date: Feb 2009
Location: Mount Holly, NJ
Vehicle:
2002 WRX
Silver

Default

Quote:
Originally Posted by Element Tuning
It's a tough situation because Subaru won't let anyone know what has or hasn't changed and when. We have 704 blocks built over 700 whp and we've had 3 failures at 550-600 whp. We reinforced a block and the problem magically goes away?

You will never know if your older 704 block is good or not until it's too late. If Subaru fixes what I believe is a problem, we'll never know because we won't take that chance with our customer motors

I can tell you with the number of calls I'm getting about these block failures, some in their 3rd block, it's far more widespread and issue than is being posted about. Now the fact they are breaking under 400whp has to do with using the oem ecu and letting too much detonation through which massively spikes cylinder pressure so it might as well be 600 hp.
Interesting. What are you doing/recommending concerning ecu problems? Are you suggesting that even regular engine management will not fix this particular issue?

Its commonly known that late 07-current impreza OEM tunes are shoddy as hell and is one of the things to first look into... but from what I got is that even the ECU should be replaced? Are you running a ROM or another piggyback unit? I would like to hear more of this hypothesis as it is interesting.

I personally think its a conspiracy with SOA and keeping their cars from being tuned. I'll write book on it just you wait
* Registered users of the site do not see these ads.
kapp_badbloodz is offline   Reply With Quote