Thread: ('11-'14) Impreza Burning Oil Quickly?
View Single Post
Old 11-16-2012, 10:57 AM   #277
79letour
Scooby Specialist
 
Member#: 302570
Join Date: Nov 2011
Location: dear old dixie
Vehicle:
2013 XV
DGM!

Default

Quote:
Originally Posted by gregorz4 View Post
Hey 79letour,
I thought I would give you an update on my oil consumption situation. So from the start of getting my brand new 2012 impreza it has been burning oil. It started at 3500km of driving ad the intervals have been ever decreasing. So at 27000 km on the odometer the interval of oil light coming on has decreased to just 1100km since the last oil light.
I guess Subaru had noticed there was a slight problem...and by slight I mean major, and they have decided to do something. It's not much, but it's a start. They have replaced my PCV valve and are continuing to monitor the situation. They said if it comes on again to come back and they will go from there. Maybe there is hope? Not too sure. As of now, they have tried the cheapest possible fix, and if it doesn't correct the problem, then I hope they will progress to the next possible solution.
How is your situation looking right now?

**I have driven 1620km now and the oil light hasn't turned on yet, maybe there is hope in this minor fix?
I'm in the same situation, mines burning more and more. I'm now burning a quart in 2000 mile or even less.
After a bunch of reading on a forester site, I'm starting to suspect the valve stems/seals. That would set off a chain reaction leading to exponential oil loss.
* Registered users of the site do not see these ads.
79letour is offline   Reply With Quote