View Single Post
Old 01-13-2013, 11:17 AM   #10
meebs
Scooby Specialist
Member Sales Rating: (5)
 
Member#: 3251
Join Date: Dec 2000
Chapter/Region: NWIC
Location: Lake Tapps, WA
Vehicle:
2009 WRX Hatch
DGM

Default

Quote:
Originally Posted by 1wrxtra View Post
I have one on mine as well. It was definitely a bitch to get on correctly and was somewhat counter intuitive. I think I got mine on with the "Gimmick" label facing the ground, and on the end that's closest to the front of the car.

Hope that makes sense.
This is the answer. Once I figured this was the correct orientation, I put a little chalk mark on the "top" to mark up where the IC will go in. I'm on just a stock TMIC.

It did leave to some guessing and trial and error to make sure this was the right way to mount it but this is it. You can set it side by side to the stock one with this orientation (gimmick label down and label on TB) and the length is pretty close stock. The angle and bend might be off by just a few degrees, but it's not much... That does mean it requires a little elbow grease to get the IC bracket bolt in. I had to pull the IC a little to get the mounting bolt in place, it was off by maybe 1/2 an inch. Once that was in then just slight pulling to get the turbo screws in place and it was good.

I've never found any silicone hose from either manufacturer I've tried to be 100% exact stock specification. As tight as it fits though, it isn't going anywhere.
* Registered users of the site do not see these ads.
meebs is offline   Reply With Quote