Thread: Ask a tuner...
View Single Post
Old 01-14-2013, 10:04 PM   #668
cuztomimportz
Scooby Specialist
 
Member#: 97904
Join Date: Oct 2005
Chapter/Region: Tri-State
Vehicle:
2002 WRX
World Rally Blue

Default

Quote:
Originally Posted by P3Auto View Post
With the power steering pump typically when air is in the system the results are noise, wheel shuddering when turning, complete loss of power steering, if you look in the fluid res you will see froth or bubbles. There is a sensor on the pump that is designed to raise the rpms slightly at low rpm to give the pump some extra power. I don't think I have seen the system raise the revs that much before however.

The first thing I would do is fix the leaks. All of the hoses and the o-ring can be changed for under $100 so you should do that first. After that I would check the basics, make sure you don't have any vac leaks or other physical issues with your engine and mods.

If after all the basics are checked you could try replacing the sensor on the power steering pump or swapping it with someone else to see if it makes a difference.

Seth
P3 Import Autowerks 907-355-6655
http://www.p3auto.com
Thanks Man! I wasn't sure if I should post that in here but thanks again. I have been monitoring my AP to make sure no codes have come up but nothing has. I was thinking that sensor on the ps pump was going haywire. I am definitely going to change out pretty much everything. Since I can't seem to find just the sensor without getting a new pump. Even rebuild kits don't come with the sensor.

Well I guess I'll be busy. Thanks I appreciate it.
* Registered users of the site do not see these ads.
cuztomimportz is offline   Reply With Quote