View Single Post
Old 02-23-2013, 05:09 PM   #9
gamma1232
Scooby Newbie
 
Member#: 249493
Join Date: Jun 2010
Chapter/Region: Tri-State
Location: Hoboken
Vehicle:
2005 STi
Silver

Default

Quote:
Originally Posted by mattyk04 View Post
Just picked up an 05 Sti last week, car came with a tbe, intake and a tune from agile. Supposedly the car put down 312 whp. I however don't think the math is adding up since peak boost is 1 notch below 1 bar. (Compression check was done 130 on all 4.) The car was the dealership owners personal car and did outstanding during the 3 hour drive home. However I noticed a weird almost burning smell when I got home, saw no fluids on the ground or anything leaking. A couple of days go by and the smell is still strong only after turning off the car. Well two days ago I see slight puffs of smoke coming from the hoodscoop and can suddenly smell coolant. I notice the piping going into the turbo is oily and see a little bit of smoke coming from behind the turbo. I am assuming I more then likely need to replace a few seals/gaskets. Any other thoughts? Should I replace with OEM parts or is aftermarket the way to go.

The car will be going to a shop on Thursday to be completely checked.

Thanks

UPDATE:
It was a torn front CV boot flinging grease onto the downpipe!

I had the same thing happen on 02 WRX. The boot ripped open and sprayed my whole engine bay and exhaust piping with grease...made a huge mess.
* Registered users of the site do not see these ads.
gamma1232 is offline   Reply With Quote