View Single Post
Old 03-07-2013, 04:21 PM   #1
grimzwrx720
Scooby Newbie
 
Member#: 337257
Join Date: Nov 2012
Chapter/Region: Tri-State
Vehicle:
2013 wrx
Crystal black silica

Default Violent shaking during acceleration

Changed my maf sensor Monday cause of check engine light need also to change o2 sensor.
After changing the maf the car runs like crap.
Idles fine but no power. Hesitates at acceleration then at around 3k rpm and up it violently shaked from front to back so hard made me think It was going to explode. Crazy.
I pulled into a gas station on the highway filled up a full tank from a quarter tank. After leaving the gas station and having to accelerate to merge on the highway it started to shake again for a sec then smoothed out. Didn't do it the rest of the 30 min highway ride.
After the changing te maf it's no where near the same.
Things I'm think it could be
I have to change the clutch it really in its way out. Not sure if that could contribute to it cause it felt like when you shift into a gear and its low of a rpm an it shakes but it felt like 100 times worse.
I know I have to change the rear o2 sensor
I have 2 little vac leaks
Maybe after disconnecting the battery during the maf changing it has reboot or read the way I drive
Maybe I need a tune I'm just trying to see what other people's suggestions are before i go need with it myself
Mods:
Perrin intake and cat back
Any suggestions or advice would be greatly appreciated
Thanks
* Registered users of the site do not see these ads.
grimzwrx720 is offline   Reply With Quote