Thread: ('11+) A/C acting weird
View Single Post
Old 03-15-2013, 02:26 AM   #17
79letour
Scooby Specialist
 
Member#: 302570
Join Date: Nov 2011
Location: dear old dixie
Vehicle:
2013 XV
DGM!

Default

Quote:
Originally Posted by kantthinkofasn77 View Post
So if I were you, I would tell them exactly this... "You guys admitted to me at my last visit that the factory overfilled my A/C system by 5 pounds and I ran the vehicle like this for a year. It is obvious that I am experiencing the long term effect of running an over-pressurized system. Either you have over-burdened my compressor and possibly the clutch is slipping, or my flow control device/thermal expansion valve is faulty due to handling high pressure, or even both components have been damaged." This thermal expansion valve on most vehicles will cycle the a/c compressor clutch to control temperature. If the expansion valve was cycling the compressor off and on too much then this would burn the clutch out. That's the best I can do for now. I have a good book thats like an encyclopedia for automotive technology from a class a took alil while back and I am sourcing my info from that. Dont let them push you around. And do not settle for less than what your expectations are. Just cause they are a big business doesnt make you any smaller. You're the boss haha
While I wholeheartedly agree with you, these people at Subaru cannot handle any amount of dissatisfaction. I've never lost my temper with them or demanded anything, but getting SOA to stand behind their product is like asking a Chinese buffet for free food.
* Registered users of the site do not see these ads.
79letour is offline   Reply With Quote