View Single Post
Old 03-15-2013, 03:59 PM   #6860
cpincy
Scooby Newbie
 
Member#: 307551
Join Date: Jan 2012
Chapter/Region: MWSOC
Location: Amherst, Ohio
Vehicle:
2004 WRX EJ20/EJ25
2009 Yamaha R6

Default

Quote:
Originally Posted by KDeiwert View Post
First off, your resurrecting something that is at least 2 years old, probably well over. Secondly, its clear from the pictures exactly what happened; the input shaft got pushed out of the trans from being overloaded. Ny-Quils car certainly made enough power at that time to cause that to happen to the trans.

You can ask either of the two most respected Evo/DSM trans builders (Jon Ripple at TRE or John Shepherd from ShepTrans), and they will tell you that they have seen this plenty of times.

Infact, I remember all the bickering about some this a while back, and people stating that no loctite was used on the bolts, and talking about how some Neon Tuning shop said that loctite was supposed to be use on all clutch cover bolts. Someone finally posted Quarter Masters instructions and an email from them stating that it wasn't necessary to use loctite on the bolts.

Everyone I have ever heard speak about Slick Motorsports has had positive things to say, and his fabrication skills are top-notch.

Sounds to me like your either trying to stir up trouble for some personal reason, or your simply ill-informed.
Seems the opposite to me, I usually hear bad things. And the WRX I bought had a hybrid swap done to it shortly before I bought it done by Slick and it was a complete hack job
* Registered users of the site do not see these ads.
cpincy is offline   Reply With Quote