View Single Post
Old 03-31-2013, 11:34 AM   #1
JackWasHere
Scooby Newbie
 
Member#: 346854
Join Date: Feb 2013
Location: Clayton, Ca
Vehicle:
2005 WRX
World Rally Blue

Default New short block, stock tune running weird

Hey all,


I'd like to begin and say, yes, I've looked at the stickies, and I've done about an hours worth if research on this topic and learned a few things.

Here's my situation. I just purchased a 2005 wrx wagon with a knocking rod. Got the short block replaced, and received the car back last night. The car has a few mods on it right now (I have a few more parts going on after smog) like a Perrin turbo inlet, Apexi cat back, and a set of headers and up pipe from a hawk eye.

When I picked up the car last night, my tech told me that when he was breaking in the engine, the power would sort of flat line after around 4500rpm in second, third, and fourth gear. Although first gear pulled all the way to red line. He tested for a boost leak and all is well there, and he explained he thinks it's the tune on the car. (Currently on a stock tune for smog) I have a Cobb AP V1 at my house, and he suggested I data log some driving, and then send him the log.

Just wondering what you guys think about this. I've read on here of a few cases where mods on a stock tune could actually yield some power loss because the ECU gets all catty whompus. I'd really appreciate any input you have on this!
* Registered users of the site do not see these ads.
JackWasHere is offline   Reply With Quote