View Single Post
Old 04-29-2013, 09:47 PM   #474
farmboss
Scooby Specialist
 
Member#: 252324
Join Date: Jul 2010
Chapter/Region: MAIC
Location: Glen Allen Va
Vehicle:
04 STi
JBP

Default

Quote:
Originally Posted by simpsonsdotcom View Post
I was going to buy them when I was there last, but my bill was already like $500 so I didn't. Just call them.

When are you going to do it? I need to order too
I jacked my car up to look under there and make sure it was the valve cover that was leaking on the up pipe and nothing else. Its not the valve cover, its the oil feed line to the turbo, it must have cracked some where.

I spent the last 30 min taking some things off the car to get ready and take the turbo off tomorrow because I want to get this fixed asap. I tried to loosen a couple of the exhaust bolts on the DP and I couldn't. My dumbass decided to use locking nuts on the Turbo to DP studs so they wouldn't back off. Well after awhile the nylon in those nuts started to melt and it stunk real bad and most likely permantly glued it self to the stud. I soaked them in PB blaster to soak over night but I don't know if I'll be able to get them or not. If anything I will probably pull the whole stud out which is fine since new ones are only 15 bucks. And theirs really not enough room to get air tools in there.

But the turbo must come off to fix this problem...this sucks...I don't want to have to take it to a shop.
* Registered users of the site do not see these ads.
farmboss is offline   Reply With Quote