View Single Post
Old 05-06-2013, 12:46 PM   #920
abosworth
Scooby Specialist
 
Member#: 53856
Join Date: Jan 2004
Chapter/Region: NESIC
Location: NoVerm Brah......
Vehicle:
2012 Speed3
Red Mica

Default

Quote:
Originally Posted by abosworth View Post
My friend changed his spark plugs on his old Impreza several years ago. We used to car pool to work and we were going out for our lunch break. Were driving along and all of a sudden we heard this hug BANG and then the car running like GAGAGAGAGAGAGAGA!!! We popped the hood and the spark plug had blown right out and was still sitting in the wire. Tried to put it back in and of course he had stripped it. He brought it somewhere and they just drilled the hole out bigger and fitted a coil around the spark plug so it would fit in the new hole.

The next time he needed to do spark plugs, he came to my house and had me help him. LOL. Got to see the little coil on the plug when I did it though.
Same friend drove his car around for like 2 years with a bad coolant temperature sensor. In the winter, the silly bastard would go through a can of starter fluid a week and would get up at like 4 AM to start his car so it would be running by the time he had to go to work. It was a 95 so it was OBD1 and I figured out how to read the codes by plugging the little electrical connecters together under the dash and reading the flashes of the check engine light. Found out it was a coolant temperature sensor. Cost like 14 bucks and took 10 minutes to put in. Car started perfectly after that. I still give him hell about that to this day.
* Registered users of the site do not see these ads.
abosworth is offline   Reply With Quote