View Single Post
Old 05-17-2013, 08:04 PM   #1
Scooby Newbie
Member#: 326537
Join Date: Jul 2012
Chapter/Region: NWIC
Location: Oregon
2005 WRX STi Wagon
Crystal Grey Metallic

Default Snaped Driveshaft Spider Journal and Question

I installed a used driveshaft when I did my STi trans swap on the WRX Wagon. On my second launch (and yes I know how to properly launch) with 320awhp and 299awtq the Spider Journal sheared (broke off) on two ends. My guess is that the previous car that the driveshaft came out of had a major rear end collision and it must have weakened or damaged the Spider Journal.

Luckily I have a 90 day waranty with the part and took it back for another used one, installed it, and now I have another problem I hope someone may be able to help me with.

When I am at half to full throttle I get vibration for about 500rpm with 1st gear at 4500rpm, 2nd gear at 3500rpm, and 3rd gear at 2500rpm.

Now I am assuming a couple possible problems, one bad yoke, two bad needle bearing, or three the driveshaft needs to be balanced. Either way I am going to have to exchange for another used driveshaft through my waranty, but I was wondering if anyone has ever experience this same problem or have a better idea of whats going on.

Thank you for your input!

I swapped the driveshaft and it is better, but it is now only vibrating at full throttle at the previously stated RPM's.

Does anyone else have any other idea's of what may be causing the vibration?
* Registered users of the site do not see these ads.

Last edited by RIBahler; 05-21-2013 at 02:09 PM. Reason: More Info
RIBahler is offline   Reply With Quote