View Single Post
Old 05-23-2013, 04:33 PM   #7
ShadowBoxer
Scooby Newbie
 
Member#: 355583
Join Date: May 2013
Chapter/Region: South East
Vehicle:
1998 Impreza Coupe
Green

Default

Supertones are now installed! I did it all by myself, and I am hella proud. I wired everything according to the instructions, negative ground and all. Disabled the old horn, and added wire loom tubing to every stretch of wire I hooked up except for the ground coming off of the Hellas. Everything works well, and LOUDLY at that...

Also I switched the front door speakers out for the SoundStreams... they don't sound as good as I was hoping, but they work and I installed them, so it's cool for now til I upgrade. (EDIT: I also have to let you know that I punched a hole in the left speaker while trying to drill the screws in to the cover harness... But then I used a very thin smear of Gorilla Glue. I think it's doing alright, but I know it might be broken. I haven't taken a look at it since I applied the glue because I'm not going to break down the door panel unless I have to. Keeping the Lows on -7 is great for the health of those speakers, especially since this subwoofer is about to blast all get out from my car.) That being said, I think they're fixed. But I don't know (and don't want to look yet).)

Next question is regarding which amplifier to get. EDIT: I got it solved...now getting the box built for my car and the sub. Going to be B.A..... MF
* Registered users of the site do not see these ads.

Last edited by ShadowBoxer; 05-29-2013 at 08:08 PM.
ShadowBoxer is offline   Reply With Quote