View Single Post
Old 06-08-2013, 06:47 PM   #1
the_toaster
Scooby Newbie
 
Member#: 358883
Join Date: Jun 2013
Chapter/Region: NESIC
Vehicle:
2008 WRX Hatchback
Silver

Default troubleshooting a keyless entry problem

I recently purchased a 2008 Subaru Impreza WRX Hatchback. It was purchased at auction and did not include a keyless entry transmitter, so I obtained one from the dealer who sold me the car. I followed these directions, and these directions to program the new remote, but neither one worked.

When I complete the steps in the first source, the car locks and then unlocks the doors to indicate that the process of programming the system was successful. The remote does not communicate with the car, though -- pressing the "lock" and "unlock" buttons does not lock or unlock the doors.

When I try following the steps in the second source, it fails near the beginning; I turn the key ten times within fifteen seconds to enter programming mode, but instead of the horn beeping twice there is an electronic beep that comes through the speakers. It enters the programming mode described in the previous paragraph.

Is it possible that I have a faulty remote?

Is it possible that the receiver in the car is malfunctioning?

How does this system work?

Has anyone dealt with this issue before? My search yielded no results, but perhaps I was not using the correct search terms.

I'd appreciate any insight anyone has to offer.

Thanks!
* Registered users of the site do not see these ads.
the_toaster is offline   Reply With Quote