Thread: Lug problems
View Single Post
Old 08-28-2013, 02:42 PM   #15
Patrick Olsen
NASIOC Supporter
 
Member#: 120
Join Date: Jul 1999
Chapter/Region: AKIC
Location: Where the Navy sends me...
Vehicle:
1997 Legacy 2.5GT
QuickSilver Metallic

Default

Quote:
Originally Posted by bratte88 View Post
Cover there[their] asses for good reason. I normally go by the manufacturers and what they say.
I understand what you're saying - I typically go by what the manufacturers say, too. But in some cases, it's abundantly obvious that the manufacturers put a disclaimer on their product for no reason other than to cover their asses against BS, not because there's some fundamental problem with the product they're selling. One need only look at how many aftermarket performance parts are marketed as "FOR OFFROAD USE ONLY" to see examples of that.

An aftermarket lug nut with a 60deg conical seat and the proper 12mm-1.25 threads has the same functionality as an OEM lug nut with a 60 deg conical seat and 12mm-1.25 threads.

Quote:
Originally Posted by bratte88 View Post
I don't show you having any pictures or you using them so ......
How long did it take you to search through the 1700+ posts that gsrcrxsi has made to see whether or not he has posted pictures of aftermarket lug nuts on OEM wheels?

Here's a picture of RAYS lug nuts on my V7 wheels:


I've also used McGard Splinedrives on those wheels.

Here's a picture of RAYS lug nuts on the '99/00 2.5RS wheels I used to have:


Here's a picture of RAYS lug nuts on my old '02+ optional BBS RK wheels:


And I don't have any pictures handy, but those RAYS lug nuts were also used with 17" UK WRX wheels that I had years ago.
* Registered users of the site do not see these ads.
Patrick Olsen is offline   Reply With Quote