View Single Post
Old 10-04-2003, 11:09 PM   #14
magnumv3
Scooby Newbie
 
Member#: 44287
Join Date: Sep 2003
Location: minnesota
Vehicle:
2003 wrx
silver

Default bad brakes

Name: Jason Hughes
Make: 2003 wrx sedan
Mileage: 6900 to current 21000
Time out of service: 3 weeks
N/Acause: Brakes Failed
Modifications: none
Submitted for warranty: no I've been trying to get it dialed in so I can dupicate it everytime so there is no question that there's a problem
My Story: I had my car in for an oil change and they performed my 7500 mile check up also. 4 hours later I first noticed the problem getting off the interstate and applied the brakes to slow down on dry smooth pavement and didn't slow down at all until I released and reapplied them. 3 days later tried to slow down for the turn to my apartment complex and they failed again causing me to go through the intersection over the curb and through the apartment sign. Causing damage to my car luckily not to me. I had pressure at the pedal in both instances but the brakes did not slow the car down at all
I contacted my dealership, Morrie's subaru in Brooklyn Park, MN and they acted like they didn't care at all about the problem because I have to prove they didn't work. My insurance towed the vehicle to a repair shop to be fixed and inspected. I should know more come Monday or Tuesday. I will keep you all informed. But the problems I read about in the 02's seems to continue on!!!
I am having the same problem with getting it to act up for dealer but I am getting it to act up more and more at about 20-30 mph hit the brakes as i hit a good bump and of course the brakes don't work abs kicks on but doesn't slow the car. It almost feels like it is just pushing air through everything.
* Registered users of the site do not see these ads.

Last edited by magnumv3; 08-05-2004 at 09:31 PM. Reason: update
magnumv3 is offline   Reply With Quote