View Single Post
Old 04-03-2004, 04:24 AM   #1
5spd Alcyone
Scooby Newbie
 
Member#: 34383
Join Date: Mar 2003
Chapter/Region: MWSOC
Location: Madison, WI
Vehicle:
1992 SVX-T3/T04E
Dark Teal Metallic

Angry battery got hooked up backwards, need help finding gremlins

Well to make a long story short, the battery got installed backwards in my SVX today. blew the fusable link. Fixed that and i have the following problemes:


1)radio works. The CD player dosnt work. But the lights on the cd player works and if i hit the eject button 2 times(yes only if twice) then the dash lights blink off for a second and then back on.

2)The clock is half lit. is keeping time perfectly.

3)Memory of stations resets everytime the car is started(radio is off when i turn it back on

4)when the car is on and i open the doors, the lights on the dash go off. I have no lights function in the doors or dome. dimmer switch does work and so does the bright button(cuases a little bit more light on the clock as well.)

5)Security system dosnt arm with the remote. lock and unlock however does work. When i hit the secuirty button on the dash it blinks repetitivly and quickly.( im not that worried about fixing this one.)


Other then these weird gremlin glitches the car runs great. I suspect i blew out a control module somewhere along the way and its a matter of finding out which ones.

BTW no fuses blew other then the fusable link, so i find these problems very odd as if the power made it past hte fusable link it would have blown any fuse that gets power when the battery is connected.


if you can help me at all it would be much apreciated . Im in madison wi.
phil
* Registered users of the site do not see these ads.
5spd Alcyone is offline