View Single Post
Old 07-12-2004, 06:28 PM   #1
animosity
Scooby Newbie
 
Member#: 59395
Join Date: Apr 2004
Chapter/Region: MWSOC
Vehicle:
2007 2.5 RS Wagon
Crystal Gray Metallic

Default rubbing sound taking corners or swirving

had my car 3 months loving and hating it (more love though :>) since ive had it there has been a rubbing sound coming from the left side of the car

dealership said ah bearings so they replaced them
its still making the noise
dealership said ah rotors and break pads
its still making the noise

1k$ later its still making the noise and no one so far can tell me whats making it but they can sure tell me what else needs to be fixed ;p


basically the sound is coming from the back left side its a metal on metal rubbing sound that always happens when i take a right turn or right swerve harder than i should and occasionally when i take a right turn at a slow speed (10mph or so)

ive taken off the back left wheel (thats where i assume the noise is coming from) its the only wheel on the car where the inside of it is filled with rust and it looks like a new caliper was put on there before i bought it so im assuming there were problems with this before anyways i didnt see anything wrong from what i could see but i didnt take anything else apart

i dont see any break dust build up or any grooves/wear in the rotor although the pads seem to be touching it i dont have a problem at all with breaking and the car doesnt seem to slow down faster than it should when im not giving it gas


so far 2 dealerships 1 mechanic and a few friends havnt figured it out so any suggestions at all are welcome im goin broke ;p



-animosity

member of the no punctuation army
* Registered users of the site do not see these ads.
animosity is offline   Reply With Quote