View Single Post
Old 08-19-2004, 03:16 PM   #3
Drakar
Scooby Specialist
 
Member#: 68402
Join Date: Aug 2004
Chapter/Region: VIC
Location: Coquitlam, BC, Canada
Vehicle:
2009 Forester XT
Camellia Red Pearl

Default

Quote:
Originally Posted by Matt Monson
What you described doesn't sound like you have any problems. Your turbo doesn't fully spool until about 3000rpms. Your BOV is a bypass BOV that reroutes the air back into the intake tract before the turbo. If you are looking for a Fast and Furious type pssttt, you won't get it on a subby. THe recirculating BOV's are the only ones that work properly with our engines and ECU's. You could get a Go Fast Bits BOV that has some sound and still recirculates, but from a functional standpoint the stock unit is good for up to at least 20 psi. Not the best expenditure of $$$ if you are just starting to mod your car...

You mis understand ill restate my problem.

The car up till 3 days ago, was fine, no BOV noise, just the turbo whine, and I was happy and the car was happy.

Now it makes loud wooshing noise from 2k to 3K at part throttle and a loud phsssttt when I let off the gas, the car stumbles and loses power all over the space and has an erradict idle now. Im suspect to the BOv but now, seeing as the car spent maybe 5 years of it's life in Palm Springs, that maybe the hoses got some dryrot and are toast causing leaks from the BOV.

Also this car is all stock. oh and Im not looking for a FNF type BOV noise. just want the car to run right
* Registered users of the site do not see these ads.
Drakar is offline   Reply With Quote