View Single Post
Old 02-14-2005, 09:55 AM   #1
AJ711
Scooby Specialist
 
Member#: 6178
Join Date: Apr 2001
Chapter/Region: MAIC
Location: Singletracks
Vehicle:
98 GM67 + 03 SG6
2 whls > 4 whls

Default power steering on its way out?

Background:
MY98 Impreza RS
103,XXX miles
Lightweight pullies installed, 10,000 miles ago

Lately (the last 3 days) my power steering pump has been making strange noises. It started as a chirping at idle, which I thought to be the belts. Tightened those down, and it still made the noise at idle. Increase the RPMs, and the noise went away.

It has progressed to a roaring type noise, especially after being driven. For instance, started the car this morning, and leaving the condo complex, it was just the squealing/chirping. When I parked the car at work (10 miles / 10 minutes later) it was the chirping with a roaring kind of noise.

Is this a "put some new fluid in me tonight" type noise? Or a "put me 6' under out in a field with a headstone and find a new one" type of noise? I'm planning on going out during lunch and buying some Redline at the local race shop (OG Racing), but am still wondering what the sound is all about.

I have no issues with turning the wheels at all, and it seems like the power steering is working fine, so I'm hoping it is just the fluid (which looks burnt, so it's probably on the old side --> my fault for negligence ). Any insight would be much appreciated.

Thanks,
AJ
* Registered users of the site do not see these ads.

Last edited by AJ711; 03-03-2005 at 05:38 PM.
AJ711 is offline   Reply With Quote