View Single Post
Old 04-07-2005, 12:21 AM   #61
engineerx
Scooby Specialist
 
Member#: 42614
Join Date: Sep 2003
Chapter/Region: SCIC
Location: Bullet-Dodging Fwy Los Angeles
Vehicle:
0405 WRX STi/S2000
AspenWhite/Silverstone

Default

yeah - true about Hydra flying one of the engineers all the way from Singapore! I loaned my car to Hydra to test and find what the problem is - as I had that problem. Andrew flew to Los Angeles - picked up my car and drove it back to the Bay Area and drove it back to L.A. a week ago.
So far, it seems a few cars suffer from the low voltage problem- mine is one of them. I wander if there's a way to "hardwire" the Hydra's power supply by means of a relay - circumventing the weak Subaru electrical system that supplies the juice. Hydra's response has been fast to fix this and I really hope the problem, is solved.

Antimullet: I agree, so far Hydra (Phil & Andrew) have been quick to tackle the problem and look for a solution. They mobilized promptly and are working on a fix - and according to Andrew - the problem was found and can be fixed! Their interest in fixing the problem , prompted me to loan my car to Hydra for a week. Well in the end it would benefit me, as well as the STi - Hydra community!

I recently ordered an Optima Yellow top and a H.O. Alternator - just to improve the electrical system and so I won't have to get rid of my radio, amps, alarm, gauges....
* Registered users of the site do not see these ads.

Last edited by engineerx; 04-07-2005 at 12:27 AM.
engineerx is offline   Reply With Quote