Welcome to the North American Subaru Impreza Owners Club Thursday July 31, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 03-18-2008, 06:16 PM   #1
DreddRS25
Scooby Specialist
 
Member#: 51642
Join Date: Dec 2003
Chapter/Region: TXIC
Location: San Antonio, Texas
Vehicle:
2001 Impreza RS
BRP

Default Cost of repairs: Motor mounts + Rear Main seal

My 01RS is finally starting to show its age. Had a leaky rear main seal for about 6 months and now have a broken motor mount. Car has 130000 and also still needs a timing belt.

1. Anyone have an idea on the cost for the broken mount and or rear main seal?

2. Is it worth repairing? As in, should I just trade it in while its still running?

I really want to buy a new vehicle in the next year. The car is worth between $3800-5700 and I owe about $2700 on the car. Any insight is much appreciated. TIA
DreddRS25 is offline   Reply With Quote
Old 03-18-2008, 06:28 PM   #2
finnRex
RIP Donny
Moderator
 
Member#: 21095
Join Date: Jul 2002
Chapter/Region: TXIC
Location: Miss you, Charlie Murphy.
Vehicle:
RIP KTH & LMFH
'09 Crystal red Tintcoat

Default

Rear main seal=6.0 hours of labor+parts(roughly $40-50). Motor mount set should run you around $150 or so, and labor should be around 2.0 hours. Shop rates vary from $60-100/hour, depending on whether you want a dealer to do it or an independent.



Mika
finnRex is offline   Reply With Quote
Old 03-19-2008, 09:02 AM   #3
anechoic
Scooby Newbie
 
Member#: 28601
Join Date: Nov 2002
Chapter/Region: NESIC
Location: Shirley, MA
Vehicle:
2007 Outback
gold opal something

Default

Assuming it's a manual, is the clutch original? You might want to consider having that done while they've got it apart to save some on the labor. I got about 145k out of the clutch in my old Legacy, although I think whoever owned it for the first 50k wasn't exactly gentle on it.

Wouldn't hurt to see what a dealership will give you in trade in its current state, and you can weigh that against the repair costs. The place where I traded in my Legacy didn't even ask about its service history, aside from whether the clutch had been replaced at some point. They either didn't notice or didn't care about the couple of rust spots, worn out suspension, or the fact that it was rollin' on bald snow tires.
anechoic is offline   Reply With Quote
Old 03-19-2008, 09:32 AM   #4
subysouth
Scooby Guru
 
Member#: 5039
Join Date: Mar 2001
Chapter/Region: South East
Location: Ocean Springs, MS
Vehicle:
2007 Outback XT
Grey 5-speed

Default

The motor mount is a fairly easy fix you could do yourself if youre inclined.

The rear main as above is a lot more work and youd definitely want to do the clutch package while youre in there.

If it were me Id repair the motor mount myself and then try to live with the oil seepage until I traded it.

ss
subysouth is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Cause of rear main seal failure DemiSlayer Factory 2.0L Turbo Powertrain 3 01-05-2008 02:24 AM
Installing a clutch? Why not throw in a new rear main seal. Tim Sanderson Transmission (AT/MT) & Driveline 0 07-08-2004 10:02 AM
rear main seal mybluesubi Service & Maintenance 11 02-09-2004 06:28 PM
rear main seal replacement?+ flywheel and pressure plate bolt torque? Haase14 Transmission (AT/MT) & Driveline 7 01-17-2003 10:42 AM
('93-'01) Rear main seal gone - 650kms? Help! JNaubur Impreza Forum 6 05-25-2001 12:29 AM


All times are GMT -4. The time now is 02:40 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.