Welcome to the North American Subaru Impreza Owners Club Monday September 22, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Water/Methanol Injection, Nitrous & Intercooler Cooling

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 04-26-2008, 04:25 PM   #1
k04sti
Scooby Specialist
 
Member#: 171773
Join Date: Feb 2008
Chapter/Region: South East
Location: tampa, fl
Vehicle:
04 wrx sti
jbp dom 3 xtr w meth!

Default how long have you had your meth

How long have you had your meth kit. I am not worried about getting meth in the short run. But I figure that those pumps will fail sometime. I am very cautious because a bad pump will equal a bad motor. I have done all the research about methanol injection and failsafes, but it still doesn't seem that "safe."
k04sti is offline   Reply With Quote
Old 04-26-2008, 09:04 PM   #2
jaxscuby
Sammo Hung
Moderator
 
Member#: 10613
Join Date: Sep 2001
Chapter/Region: South East
Location: S Ga / Hell Rock
Vehicle:
2002 USDM WRX
WRB

Default

if installed properly most systems with fail safe
will get your ecu to open wastegate on turbo
and you will have zero boost.
jaxscuby is offline   Reply With Quote
Old 04-26-2008, 09:55 PM   #3
djerickd
Scooby Guru
 
Member#: 3782
Join Date: Jan 2001
Chapter/Region: South East
Location: Tampa B*tch!
Vehicle:
02 WRX WFC#040
Clean on 19's

Default

I've had my Aquamist HFS-5 running for over a year now.
djerickd is offline   Reply With Quote
Old 04-27-2008, 05:29 PM   #4
Labonte MotorSports
Vendor
 
Member#: 162593
Join Date: Oct 2007
Default

A bad water pump will also take out our motor. There are no monitoring systems for water pumps outside of a temp gauge. Our Injection Fail Safe (IFS-10) can be used to limit boost if your meth ever stops flowing.
Labonte MotorSports is offline   Reply With Quote
Old 04-28-2008, 04:17 AM   #5
k04sti
Scooby Specialist
 
Member#: 171773
Join Date: Feb 2008
Chapter/Region: South East
Location: tampa, fl
Vehicle:
04 wrx sti
jbp dom 3 xtr w meth!

Default

Quote:
Originally Posted by Labonte MotorSports View Post
A bad water pump will also take out our motor. There are no monitoring systems for water pumps outside of a temp gauge. Our Injection Fail Safe (IFS-10) can be used to limit boost if your meth ever stops flowing.
But, is the fail safe fast enough to react to the sudden stop in methanol injection? I understand it working under maybe 50% throttle but under wot it just doesn't seem like it would be fast enough for you to not damage anything
k04sti is offline   Reply With Quote
Old 04-28-2008, 09:36 AM   #6
Labonte MotorSports
Vendor
 
Member#: 162593
Join Date: Oct 2007
Default

Here is a link to a thread on another forum where a customer posted a video of the Injection Fail Safe in operation. The customer wired up a switch to kill power to his pump. He then goes WOT and you will see the IFS never lets him make full boost.

http://www.evolutionm.net/forums/sho...hlight=labonte

It is fast enough for you.
Labonte MotorSports is offline   Reply With Quote
Old 04-27-2008, 07:38 PM   #7
Ultimate Collision Center
Vendor
 
Member#: 69072
Join Date: Aug 2004
Chapter/Region: Tri-State
Location: Peekskill
Default

I ran 65+ gallons through my pump and 2 years of abuse and it kept going...I cleaned it up and replaced the seals at that point and sold the kit as I had sold my evo...
Ultimate Collision Center is offline   Reply With Quote
Old 04-28-2008, 04:26 PM   #8
k04sti
Scooby Specialist
 
Member#: 171773
Join Date: Feb 2008
Chapter/Region: South East
Location: tampa, fl
Vehicle:
04 wrx sti
jbp dom 3 xtr w meth!

Default

Wow great link. I am contemplating meth now. I have been contemplating for a while, but I just wasn't sure thanks for the info!!!
k04sti is offline   Reply With Quote
Old 05-02-2008, 11:07 PM   #9
El_Pitufo
Scooby Newbie
 
Member#: 109271
Join Date: Mar 2006
Chapter/Region: PRSIC
Vehicle:
2004 STI

Default

I have had mine for 2000k miles and 4 -1gal tanks and its been working grate. The key is having a fail safe, that is all.
El_Pitufo is offline   Reply With Quote
Old 05-03-2008, 08:52 PM   #10
k04sti
Scooby Specialist
 
Member#: 171773
Join Date: Feb 2008
Chapter/Region: South East
Location: tampa, fl
Vehicle:
04 wrx sti
jbp dom 3 xtr w meth!

Default

So, you've had it for 2 million miles?
k04sti is offline   Reply With Quote
Old 05-04-2008, 06:57 AM   #11
Aquamist
NASIOC Manufacturer
 
Member#: 110029
Join Date: Mar 2006
Location: Sussex, England
Vehicle:
2004 Citroen Picasso
Silver

Default

Quote:
Originally Posted by k04sti View Post
So, you've had it for 2 million miles?
I have only just noticed it!
Aquamist is offline   Reply With Quote
Old 05-04-2008, 02:53 PM   #12
albie1kanobi
Scooby Newbie
 
Member#: 101607
Join Date: Nov 2005
Chapter/Region: South East
Location: Gibsonton,FL
Vehicle:
06 Subaru STi
Aspen White

Default

over a year on my smc and i still have my original pump.
albie1kanobi is offline   Reply With Quote
Old 05-04-2008, 05:46 PM   #13
shortys64
Scooby Specialist
 
Member#: 74453
Join Date: Nov 2004
Chapter/Region: SCIC
Location: Irvine
Vehicle:
04 WRX-PSM

Default

Quote:
Originally Posted by albie1kanobi View Post
over a year on my smc and i still have my original pump.
+1
no problems here
shortys64 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
How long have you been driving at stage2 before you got your first tune? bullysonwrx Newbies & FAQs 12 05-29-2010 10:07 AM
How long have you had your car & Why do you want to get rid of it? Kroze General Community 55 11-03-2009 09:50 AM
Random Topic: How long have you had your subaru for? rekondyte Vancouver Impreza Club Forum -- VIC 30 08-10-2006 04:26 AM
How long have you had your subaru for? rekondyte Vancouver Impreza Club Forum -- VIC 40 06-16-2006 02:51 AM
How long have you gone w/o your subie? Jonathan_Yi General Forum Archive 32 01-07-2001 01:34 AM


All times are GMT -4. The time now is 03:23 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.