Welcome to the North American Subaru Impreza Owners Club Thursday December 18, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Pre-2002 Factory Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 01-27-2009, 07:27 PM   #1
98jdmlegacy
Scooby Newbie
 
Member#: 139744
Join Date: Feb 2007
Chapter/Region: NWIC
Location: Belgrade MT
Vehicle:
04 STi
wrb

Default no spark? whats the deal?

my friend has a 91 legacy turbo. we just got done putting on a new water pump and timing belt. After putting everything back together the car wont start. its getting fuel but no spark. what could be the problem? any help is well apreciated
98jdmlegacy is online now   Reply With Quote
Old 01-28-2009, 12:03 AM   #2
reddevil
Scooby Guru
 
Member#: 64673
Join Date: Jun 2004
Chapter/Region: NWIC
Location: portland
Vehicle:
1990 Legacy wagon
goes 12.387 @ 116.5

Default

Odds are you installed the timing belt wrong. Which mark did you use on the crank pulley? The front mark, or the rear mark?
reddevil is offline   Reply With Quote
Old 01-28-2009, 06:33 AM   #3
thad
Scooby Newbie
 
Member#: 176616
Join Date: Apr 2008
Location: fresno
Vehicle:
1994 impreza
white

Default

also check cam and crank position sensors.
thad is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Whats the deal with the red pinstripe around the 06 grill? ILSMKU2 Interior & Exterior Modification 44 08-22-2009 12:31 AM
Whats the Deal With the Womenz not Liking the Catcalling? TarmacRally Off-Topic 50 07-12-2007 09:10 PM
Whats the deal with gas grills... why no charcoal? Hazdaz Off-Topic 39 05-28-2007 05:33 PM
No cats, no CEL- what's the deal? codean Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 7 07-23-2002 10:26 AM
Whats the deal with the power surge when you let off the gas? Keith Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 4 05-17-2001 11:11 AM


All times are GMT -4. The time now is 09:45 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.