Welcome to the North American Subaru Impreza Owners Club Friday July 25, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Subaru Conversions

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 03-12-2009, 10:50 PM   #1
E_Swift
Scooby Newbie
 
Member#: 152711
Join Date: Jun 2007
Location: PDX
Question Swapped: A/T -> 5MT 2005 2.5RS, one small problem

So, I have almost complete success now in my swap of a 2002 2.5RS sedan 5MT into my 2005 2.5RS wagon. (Two transmission rebuilds later...)

So far, about 700 miles - after this weekend we'll have 1100 miles on the swap.

Successes:
Transmission and clutch mechanically work great (after center diff, case, and transfer shaft swap)
No fluid leaks of any kid (had to replace front axle seals)
ABS system works fine, no issues
Reverse lights are wired and work as expected
Speed sensor is wired and functional
Ignition system is properly wired with clutch switch

However, I am still reading a P0600 Code with my scanner, and there is a solid check engine light and a flashing cruise control light. The cruise control system does not currently work.

Luckily, the car runs fine, but I would like to fix this problem and regain my cruise control for commutes.

I understand that the P0600 code is for a Serial Communications Error, basically the ECM can't find the TCM and isn't pleased.

Looking at the ECM pinouts for the drive by wire 2005 SOHC engine, there doesn't appear to be the pin that tells the computer if it is a manual or an automatic, which I believe is common in previous Subarus.

Anyone know what I need to do to convince my ECM that there isn't an automatic trans any more?

Looked briefly at the ROMS for the ECM, and I think the manual and auto are identical. I think that if I get a Tactrix cable, I can permanently disable the check engine light, but I don't think that will get me back the cruise control.

Any advice would be greatly appreciated!

Cheers!
E_Swift is offline   Reply With Quote
Old 03-12-2009, 11:55 PM   #2
suberdave
NASIOC Supporter
 
Member#: 101865
Join Date: Nov 2005
Chapter/Region: NWIC
Location: Covington, WA
Vehicle:
88 GL-10 STi
silver

Default

i am having a simular problem with a 97 auto to 5mt. but its a P1127 or a P1227... same problem trans id code.

can someone help???

-=Suberdave=-
www.suberdave.com
suberdave is offline   Reply With Quote
Old 03-17-2009, 06:04 PM   #3
E_Swift
Scooby Newbie
 
Member#: 152711
Join Date: Jun 2007
Location: PDX
Default

Anyone have any actual input?
E_Swift is offline   Reply With Quote
Old 09-08-2009, 12:50 PM   #4
scOOtNsOOby
Scooby Newbie
 
Member#: 211094
Join Date: May 2009
Chapter/Region: MWSOC
Location: in my house
Vehicle:
03 WRX Wagon
rotated holset Hx35!!!

Default

i thought i heard that u need to disconnect a ground that tells it wheter its auto or manual
scOOtNsOOby is offline   Reply With Quote
Old 09-08-2009, 01:24 PM   #5
E_Swift
Scooby Newbie
 
Member#: 152711
Join Date: Jun 2007
Location: PDX
Default

Thanks, but I think that is only the case on the pre-2005's.

There doesn't seem to be any pin out for this on the 2005 ECM, which happens to be different from the earlier ones.

05 was the first year for DBW on the 2.5 NA, as well as the 32-bit system.

If you know which pin it is, and what year ECUs it applies to, post it up.
E_Swift is offline   Reply With Quote
Old 09-11-2009, 09:57 AM   #6
AJ711
Scooby Specialist
 
Member#: 6178
Join Date: Apr 2001
Chapter/Region: MAIC
Location: Singletracks
Vehicle:
98 GM67 + 03 SG6
2 whls > 4 whls

Default

Can you source a manual ECU for your model year? That may be the difference. Maybe find someone who is willing to let you plug theirs in briefly to make sure that it will solve the problem and then source a manual ECU on your own.

As for tricking the ECU, if you knew what it was looking for from the TCU (+12v, wave form, ground) that would help. Could you wire the TCU in temporarily in order to find out?
AJ711 is online now   Reply With Quote
Old 09-11-2009, 11:43 PM   #7
69subaru360
Scooby Guru
 
Member#: 159682
Join Date: Sep 2007
Chapter/Region: NESIC
Location: Maine
Vehicle:
1995 WRX
1998 2.5 RS

Default

I am thinking you need to reflash your ECU with a 5 speed ROM. 2005 is the first year of reflashable 2.5 NA cars right?
69subaru360 is offline   Reply With Quote
Old 09-12-2009, 11:26 PM   #8
scOOtNsOOby
Scooby Newbie
 
Member#: 211094
Join Date: May 2009
Chapter/Region: MWSOC
Location: in my house
Vehicle:
03 WRX Wagon
rotated holset Hx35!!!

Default

http://forums.nasioc.com/forums/showthread.php?t=378813


does this help? look at post 10,11 and 12
scOOtNsOOby is offline   Reply With Quote
Old 09-13-2009, 08:22 AM   #9
69subaru360
Scooby Guru
 
Member#: 159682
Join Date: Sep 2007
Chapter/Region: NESIC
Location: Maine
Vehicle:
1995 WRX
1998 2.5 RS

Default

Quote:
Originally Posted by scOOtNsOOby View Post
http://forums.nasioc.com/forums/showthread.php?t=378813


does this help? look at post 10,11 and 12
That only applies to 02 and possibly 03. After that the ECU uses a different ROM for manual and auto.
69subaru360 is offline   Reply With Quote
Old 09-13-2009, 09:59 AM   #10
E_Swift
Scooby Newbie
 
Member#: 152711
Join Date: Jun 2007
Location: PDX
Default

Quote:
Originally Posted by 69subaru360 View Post
That only applies to 02 and possibly 03. After that the ECU uses a different ROM for manual and auto.
Now this is what really confuses me.

If you look at ROMs, as soon as a given model picked up the 32bit ECU (at the same time, picking up drive-by-wire throttle pedal) the separate A/t and M/t ROMS become one.

I have confirmed that my map includes both auto and manual tables. (Via tactrix connection). Also, any of the sites that you can download the maps from have only one, which works for both auto and manual. So, this 32-bit ECU doesn't seem to be able to be tricked by an external wire, and are not ROM-specific either.

So that leaves a physical hardware difference, inside the case... Unless I'm missing something.
E_Swift is offline   Reply With Quote
Old 09-15-2009, 11:57 AM   #11
johnpik
Scooby Newbie
 
Member#: 218383
Join Date: Jul 2009
Default small question - diff swaping?

i am looking into the option of swaping my a/t to m/t, and after several service shops they told me i need to swap the rear diff also. is this true?

my Impreza is 2003 GX 2.0L AWD non turbo automatic.
johnpik is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
FS: 2005 STI Front Struts, Flywheel? 2005 2.5RS springs, Spare, COBB Springs + MORE Miniman SCIC Private Classifieds 10 05-21-2010 11:55 AM
FS: 2005 STI Front Struts, Flywheel? 2005 2.5RS springs, Spare, COBB Springs + MORE Miniman Suspension/Brakes/Handling 7 05-21-2010 11:51 AM
Local places for a 2.5L WRX swap to 2005 2.5RS boostdriven Vancouver Impreza Club Forum -- VIC 28 04-10-2007 06:15 PM
Gravel roads, one '01 2.5RS, one '02 WRX, two guys, and a girl I Like It Sideways Member's Car Gallery 33 10-17-2006 08:26 AM
2005 2.5RS or 2006 2.5i or 2006 2.5 wagon Prelude Canada Region Forum 16 09-21-2005 04:10 PM


All times are GMT -4. The time now is 03:54 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.