Welcome to the North American Subaru Impreza Owners Club Saturday December 27, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated with bolt-on Forced Induction Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 04-17-2002, 02:51 PM   #1
Jewbaru
Scooby Specialist
 
Member#: 1994
Join Date: Jul 2000
Location: "Teh Hebro Town"
Vehicle:
2013 Impreza WRX
WRB

Default Is my fuel pump crapping out on me?

I drove out to the city today to run an errand, and when I was stopped at a light, with the radio down, I could hear a loud whining coming from the car. I listened for a bit, and it's coming from the rear passenger side of the car, where the fuel pump is. When the car was idling on the timer, I walked around the car and listened. The whine was REALLY loud. The car doesn't feel any different, but the A/F guage shows it's running a touch leaner under cruise than it was normally. Still well within stoich, however. I thought I felt the car hesitating a little when I was cruising, but I may just be paranoid, since the a/f guage wasn't fluttering into the lean range.

The pump is a Walbro, and it's not even a year old yet.
Jewbaru is offline   Reply With Quote
Old 04-17-2002, 02:53 PM   #2
8Complex

Moderator
 
Member#: 922
Join Date: Feb 2000
Chapter/Region: MWSOC
Location: Schaumburg, IL
Vehicle:
04 FXT
Red

Default

Mine has been fairly loud lately, too, but I haven't noticed any pressure fluctuations... hmmmm....
8Complex is offline   Reply With Quote
Old 04-17-2002, 02:54 PM   #3
Impreza Rider
Scooby Specialist
 
Member#: 756
Join Date: Jan 2000
Chapter/Region: MAIC
Location: Ashburn, Va
Vehicle:
2003 Legacy L wagon
2009 Kawasaki C14

Default

Mine has always been really noisy since the begining if that makes you feel better.
Impreza Rider is offline   Reply With Quote
Old 04-17-2002, 03:00 PM   #4
Jewbaru
Scooby Specialist
 
Member#: 1994
Join Date: Jul 2000
Location: "Teh Hebro Town"
Vehicle:
2013 Impreza WRX
WRB

Default

hmm, could it just be ambient temps affecting the cooling, and making it louder? It's been REALLY hot here lately, looking at the thermometer on my PC, it's 87 outside right now.
Jewbaru is offline   Reply With Quote
Old 04-17-2002, 03:13 PM   #5
Impreza Rider
Scooby Specialist
 
Member#: 756
Join Date: Jan 2000
Chapter/Region: MAIC
Location: Ashburn, Va
Vehicle:
2003 Legacy L wagon
2009 Kawasaki C14

Default

It's been hot here too, and that's when I have noticed it more
Impreza Rider is offline   Reply With Quote
Old 04-17-2002, 03:35 PM   #6
Jewbaru
Scooby Specialist
 
Member#: 1994
Join Date: Jul 2000
Location: "Teh Hebro Town"
Vehicle:
2013 Impreza WRX
WRB

Default

Quote:
Originally posted by Impreza Rider
It's been hot here too, and that's when I have noticed it more
ahh, ok, I feel better now.
Jewbaru is offline   Reply With Quote
Old 04-18-2002, 08:17 AM   #7
Elliot
Scooby Specialist
 
Member#: 12732
Join Date: Nov 2001
Location: Dorado Puerto Rico
Vehicle:
2000 2.5RS-T
Titanium silver

Default Fuel problem!!!

I have a 2 weeks old walbro fuel pump. the same day it was on the car the noise was horrible. For now there is not much that we can do. You can try a fuel pressure regulator to decrease the pressure before the injectors. that should help a little!!! but keep in mind that these pumps were made for racing purposes, comfort is not a big deal in their design spec!!! Also try to keep the fuel level high. That will help to reduce the noise. sound waves don't like liquids!!!!!


Elliot
Elliot is offline   Reply With Quote
Old 04-18-2002, 12:17 PM   #8
Jon Bogert
Scooby Specialist
 
Member#: 1133
Join Date: Mar 2000
Location: SE PA
Vehicle:
09 GTR, 02 996 C4S
95 993 C4, 71 911, 04 STI

Lightbulb

My Walbro always made noise, but started whining badly after about 9 months. Got a Supra TT pump which is quiet, and kept the Walbro as a spare.
Jon Bogert is offline   Reply With Quote
Old 04-18-2002, 02:47 PM   #9
the Dabbler
Scooby Newbie
 
Member#: 4540
Join Date: Feb 2001
Vehicle:
MY00 2.5RS Sedan
Abnormally Aspirated

Default

My Walbro has also been very loud, since day one. Seems to be moving gas fine, though.
the Dabbler is offline   Reply With Quote
Old 04-18-2002, 11:43 PM   #10
Legacy GTR
Scooby Specialist
 
Member#: 9316
Join Date: Aug 2001
Location: Litchfield Park, AZ
Vehicle:
1997 Legacy GT
14.767@93.54

Default

Same thing hear. I've had mine for about 15 months. Then about 2 weeks ago it started. Kinda pissing me off, mostly just because I wasen't sure if it was ok.
Mike
Legacy GTR is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Is my fuel pump getting weak or is it the Turbo? ClayMac Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 12 11-20-2008 04:59 PM
Access Port Crapped out on me during very first tune Mr Nice Guy AccessPort 8 06-30-2006 08:19 AM
HELP! My car is crapping out on me synickle General Community 4 12-03-2005 01:27 PM
Is my fuel pump going bad? Or is it worse? NicGordon Service & Maintenance 5 10-15-2002 03:43 PM
Attn: Brullen Crapped Out On Me booger Normally Aspirated Powertrain 4 07-15-2002 01:54 PM


All times are GMT -4. The time now is 06:55 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.