Welcome to the North American Subaru Impreza Owners Club Friday August 22, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 04-26-2009, 07:13 PM   #1
nikesb1111
Scooby Newbie
 
Member#: 206369
Join Date: Mar 2009
Chapter/Region: NESIC
Location: MA
Vehicle:
1993 impreza
blue

Default gauge problems

So what kind of plug should i be looking for to go into the back of the gauge cluster? Is it just for the tach? Also the fuel gauge doesnt work and the gauges dont light up. What could be the problem? Thank you

nikesb1111 is offline   Reply With Quote
Old 04-26-2009, 07:30 PM   #2
Cougar4
Scooby Specialist
 
Member#: 53443
Join Date: Jan 2004
Location: Anchorage, AK
Vehicle:
2001 LL Bean Outback
Winestone

Default

If none of the dash lights are working then check for a bad fuse. If just some of the gauge lights are out then there may be some burned out bulbs. You get to them by turning those black bulb sockets. Most of the problems with fuel gauges are due to sensor problems in the tank. I would check that area first.
Cougar4 is offline   Reply With Quote
Old 04-26-2009, 08:08 PM   #3
nikesb1111
Scooby Newbie
 
Member#: 206369
Join Date: Mar 2009
Chapter/Region: NESIC
Location: MA
Vehicle:
1993 impreza
blue

Default

Do you know what the plug in the back is for? it looks like just a plastic hole. Not sure
nikesb1111 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
boost gauge problem scoobi02 Factory 2.0L Turbo Powertrain 1 01-12-2002 08:08 PM
Boost gauge problem, need some help! datdudedennis Factory 2.0L Turbo Powertrain 4 11-15-2001 10:01 PM
Boost Gauge Problem BurtonCR Factory 2.0L Turbo Powertrain 2 06-12-2001 09:02 AM
('93-'01) Gauge problem!? MichiganRS Impreza Forum 0 05-27-2001 09:40 PM
a\f gauge problems please help fast brendon Normally Aspirated Powertrain 3 02-20-2001 09:04 AM


All times are GMT -4. The time now is 01:03 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.