Welcome to the North American Subaru Impreza Owners Club Sunday July 13, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 06-29-2009, 05:21 PM   #1
Danny@VIPtuning
Scooby Specialist
 
Member#: 69070
Join Date: Aug 2004
Location: San Francisco, CA
Default Shift Lock and Brake Lights Dont Work??

i'm at work right now and i dont have the car with me but i'm just trying to look up what could possibly be wrong with my car. its a 97 impreza outback. the brake lights dont work and i cant take my car out of park. the fuse is good. when i searched, someone said something about a little black box on top of the brake pedal. is this probably the problem or could it be something else?
Danny@VIPtuning is offline   Reply With Quote
Old 06-29-2009, 05:54 PM   #2
Jubert69
Scooby Specialist
 
Member#: 167739
Join Date: Dec 2007
Chapter/Region: Tri-State
Location: CT
Vehicle:
04 WRX
ej207 spec C

Default

The black box I think the person is this.

http://www.surrealmirage.com/subaru/...ontroller1.jpg

Look like this? The shift lock system is used on the automatics to keep you from moving the gear selector out of park unless your foot is on the brake.
Jubert69 is offline   Reply With Quote
Old 06-29-2009, 09:50 PM   #3
munkis
Scooby Guru
 
Member#: 1847
Join Date: Jul 2000
Chapter/Region: Tri-State
Location: brokenmotorsports.com
Vehicle:
Team Broken: V6 GF
rallyarmor.com

Default

Well I would first check the brake light switch.

If the brake light switch is no good, no signal sent to interlock module = no come out of park.
munkis is offline   Reply With Quote
Old 06-29-2009, 11:15 PM   #4
Danny@VIPtuning
Scooby Specialist
 
Member#: 69070
Join Date: Aug 2004
Location: San Francisco, CA
Default

how do i tell if its a faulty brake switch? is there a way or do i just have to change it out to find out?

Last edited by Danny@VIPtuning; 06-29-2009 at 11:27 PM.
Danny@VIPtuning is offline   Reply With Quote
Old 06-29-2009, 11:43 PM   #5
Danny@VIPtuning
Scooby Specialist
 
Member#: 69070
Join Date: Aug 2004
Location: San Francisco, CA
Default

so i took apart the switch and put it back together and it works now but should i get a new one?
Danny@VIPtuning is offline   Reply With Quote
Old 06-30-2009, 03:53 PM   #6
Danny@VIPtuning
Scooby Specialist
 
Member#: 69070
Join Date: Aug 2004
Location: San Francisco, CA
Default

to the top
Danny@VIPtuning is offline   Reply With Quote
Old 06-30-2009, 08:35 PM   #7
Jubert69
Scooby Specialist
 
Member#: 167739
Join Date: Dec 2007
Chapter/Region: Tri-State
Location: CT
Vehicle:
04 WRX
ej207 spec C

Default

Wouldn't hurt to get another one.
Jubert69 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Brake Lights Dont Work 06WRXMIKE Electrical & Lighting 2 05-04-2009 07:18 PM
Brake Lights Dont Work 06WRXMIKE Brakes, Steering & Suspension 0 05-04-2009 05:54 PM
Reverse light dont work and CEL's Twiztidunreal Electrical & Lighting 1 08-06-2008 12:50 PM
Custom mounted turbo timer, STi shift trim, 3rd brake light, gauge pod and more! eastcoastbumps Interior/Dressup/Audio & Security 18 07-20-2007 07:15 PM
Installed new HU and dash lights dont work, help! wrxboy944 Car Audio, Video & Security 10 11-30-2005 07:29 PM


All times are GMT -4. The time now is 03:01 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.