Welcome to the North American Subaru Impreza Owners Club Saturday July 12, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 06-29-2010, 03:44 AM   #1
feint05
Scooby Specialist
 
Member#: 152984
Join Date: Jul 2007
Chapter/Region: SCIC
Location: san diego
Vehicle:
2004 jewbaru
jewbuilt, polish tuned

Default help: cooling system this car is kicking my ass

car 1998 forester 2.5na phase 1

the previous mechanic drilled holes in the stock thermostat to "keep it cool"
so i bought a new failsafe thermostat and gasket as well as bypassing the throttle body deicer, installed them and now

i did my best to burp the cooling system
the system doesnt have any leaks but wont fully pressurize
the coolant temp sender never moves, it just stays at the bottom

so what do you think, air pocket at the top?


FOUND IT theres a one wire connector to the right of the coolant temp sender, it is part of the sensor and once it was rehooked it was fixed

Last edited by feint05; 06-30-2010 at 03:30 AM.
feint05 is offline   Reply With Quote
Old 06-29-2010, 04:01 AM   #2
Henry H
Scooby Newbie
 
Member#: 184330
Join Date: Jul 2008
Location: Southern California
Vehicle:
2008 Impreza 2.5i
Dark Grey Metallic

Default

Quote:
Originally Posted by feint05 View Post
the previous mechanic drilled holes in the stock thermostat to "keep it cool"
That makes my head hurt.

Thermostat either doesn't work or isn't hooked up properly. You might want to check for voltage levels while getting the car warmed up. If you feel there might still be pockets of air then try this.

The the front end as high as you can (uphill, jack it up, combo of both with GREAT CHOCKS)
Uncap your radiator (engine cold)
Turn on heater full blast
Turn on car
Wait for more burping
You know the rest
Henry H is offline   Reply With Quote
Old 06-29-2010, 09:04 AM   #3
Patrick Olsen
NASIOC Supporter
 
Member#: 120
Join Date: Jul 1999
Chapter/Region: AKIC
Location: Where the Navy sends me...
Vehicle:
1997 Legacy 2.5GT
QuickSilver Metallic

Default

Quote:
Originally Posted by feint05 View Post
i did my best to burp the cooling system
the system doesnt have any leaks but wont fully pressurize
the coolant temp sender never moves, it just stays at the bottom

so what do you think, air pocket at the top?
It's entirely possible that the coolant temp sender is dead, which would explain the gauge never moving.

On my '97 and '99 2.5GTs, which is the same engine, the radiator has a vent plug on the top on the passenger side (opposite end from the radiator cap). Did you remove that while filling? That definitely helps get air out of the system as you top off the radiator. I've never had to resort to any sort of tricks to get the system full. Well, I guess that's not entirely true. I'll remove the vent plug and radiator cap, fill the system, then reinstall the vent plug and squeeze the upper radiator hose a few times. That usually forces a bit of air out and the level drops slighly at the fill neck. I then remove the vent plug again, top off the radiator, and reinstall the vent plug and radiator cap.

Quote:
Originally Posted by Henry H View Post
That makes my head hurt.
Concur!

Quote:
Originally Posted by Henry H View Post
Thermostat either doesn't work or isn't hooked up properly. You might want to check for voltage levels while getting the car warmed up.
Not sure what you're thinking of here, but the thermostat isn't "hooked up" to anything, and certainly doesn't have any voltage going to it! Maybe you meant to say the coolant temp sending unit?
Patrick Olsen is offline   Reply With Quote
Old 06-29-2010, 03:26 PM   #4
Henry H
Scooby Newbie
 
Member#: 184330
Join Date: Jul 2008
Location: Southern California
Vehicle:
2008 Impreza 2.5i
Dark Grey Metallic

Default

Quote:
Originally Posted by Patrick Olsen View Post
Not sure what you're thinking of here, but the thermostat isn't "hooked up" to anything, and certainly doesn't have any voltage going to it! Maybe you meant to say the coolant temp sending unit?
Oops, changed thermostat on house last night. But yes.^^
Henry H is offline   Reply With Quote
Old 06-29-2010, 03:21 PM   #5
feint05
Scooby Specialist
 
Member#: 152984
Join Date: Jul 2007
Chapter/Region: SCIC
Location: san diego
Vehicle:
2004 jewbaru
jewbuilt, polish tuned

Default

the coolant temperature sender was working yesterday before hand, i kind thought maybe i have an air pocket that leads up to it.
keep in mind im not making any pressure which is a bad sign, gonna do this all over again today
feint05 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Subaru Cooling System Conditioner - What IS this stuff? jac04 Service & Maintenance 51 10-17-2007 09:54 AM
This toddler will kick your ass ktnndal Off-Topic 26 05-31-2007 04:53 PM
So I drove KC's car and it kicked my ass. ratt_finkel Motorsports 14 03-29-2007 08:24 PM
So, my roommate wants to kick my ass TheRex Off-Topic 36 01-18-2005 01:11 AM
this intranet worm is kicking my ass *help* Johnny Knoxville Off-Topic 13 08-17-2003 07:43 PM


All times are GMT -4. The time now is 11:47 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.