Welcome to the North American Subaru Impreza Owners Club Monday September 22, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 02-21-2011, 09:24 PM   #1
can'tread503
Scooby Specialist
 
Member#: 187181
Join Date: Aug 2008
Chapter/Region: NWIC
Location: Clatskanie,Or
Vehicle:
93 maroon impreza
maroon

Default rer main seal problem

ok so i recently just put a 22e in my 93 impreza and put my buddies act lightweight flywheel in my car that he had in his 07 impreza 2.5i to get to the point i have replace 2 rear main seals in the past 2 weeks cuz they keep leaking oil could the flywheel be doing this cuz i never had this problem unil i put the flywheel in and my clutch keeps slipping i bought a new clutch and had the flywheel resurfaced.
can'tread503 is offline   Reply With Quote
Old 02-21-2011, 10:18 PM   #2
olsen726
Scooby Specialist
 
Member#: 154175
Join Date: Jul 2007
Chapter/Region: NWIC
Location: PDX
Vehicle:
07 Impreza Wagon
2.5i???

Default

chief your clutch is probably slipping because the main seal is leaking oil on it
olsen726 is offline   Reply With Quote
Old 02-21-2011, 11:42 PM   #3
Wrencher86
Scooby Newbie
 
Member#: 250463
Join Date: Jun 2010
Location: Evanston, Il
Vehicle:
2010 Impreza 2.5i
Silver

Default

Did you build the engine? What's your end play on the crankshaft? Did you put the right thrust bearing in?

If the crankshaft is moving back and forth more than it should it can roll the seal out.
Wrencher86 is offline   Reply With Quote
Old 02-22-2011, 09:24 AM   #4
Storm
Scooby Guru
 
Member#: 5218
Join Date: Mar 2001
Chapter/Region: MWSOC
Location: SAUL'S Motorsports
Vehicle:
96L Most Over-
Developed Beater

Default

I'd be more concerned with the condition of the crank and/or installation method.

If the crank has a burr on it, it'll just tear a perfectly good seal in no time. If you drive the seal in too far, it can (will) leak. A deep groove worn in the crank will also fail to seal.


Jay
Storm is offline   Reply With Quote
Old 02-22-2011, 01:21 PM   #5
renob123
Scooby Specialist
 
Member#: 41986
Join Date: Aug 2003
Chapter/Region: NWIC
Location: Hillsboro, OR
Vehicle:
'06 STI/'85 Brat

Default

Quote:
Originally Posted by Storm View Post
If you drive the seal in too far, it can (will) leak.
I was thinking this as well. I'm not sure if you do your work yourself, but a friend of mine in West Linn does this sort of thing all the time in his shop. PM me if you want to give him a try.

Jacob
renob123 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Possible problems with rear main seal install cdigerlando Service & Maintenance 5 01-13-2011 02:53 PM
Rear Main Seal problem rivman05 Service & Maintenance 2 12-01-2007 08:02 AM
Replaced front main seal and oil pump o-ring archer Normally Aspirated Powertrain 4 12-28-2001 03:28 AM
('93-'01) Rear main seal gone - 650kms? Help! JNaubur Impreza Forum 6 05-25-2001 12:29 AM
Front main seal, timing belts -oil pump&water pump? immortal_suby SVX Forum Archive 3 06-25-2000 07:15 PM


All times are GMT -4. The time now is 08:31 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.