Welcome to the North American Subaru Impreza Owners Club Monday July 28, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 02-07-2012, 01:51 PM   #1
emsmap
Scooby Guru
 
Member#: 159334
Join Date: Sep 2007
Chapter/Region: MAIC
Location: Martinsburg, WV
Vehicle:
02 WRX, 99RS, 96L
AP3,PPG,FMIC, Big turbo

Default Steam coming out of radiator cap. Please help

I am having a weird issue with my Mitshimoto aluminum radiator. I have maybe only 2000 miles on this radiator. I just installed my rotated turbo kit on my 2002 WRX. My radiator cap is steaming around the neck. Its a 1.3 bar (19 lbs) cap. My overflow tank is working fine and fills up if need be. I don't understand how this cap can already be bad unless I am having a pressure problem. I replaced the thermostat with an OEM one and also replaced the cap with a new one. Still steams. I took the cap off and the steam was coming out the top of the radiator pretty bad. The only thing left to do is get the radiator flushed. I do not overheat at all. My fan also comes on at 204 degree F like it always has. Im stumped now Any help is appreciated. Thank you
emsmap is online now   Reply With Quote
Old 02-07-2012, 04:05 PM   #2
WRXSD
Scooby Newbie
 
Member#: 136539
Join Date: Jan 2007
Location: San Diego
Vehicle:
2005 WRX Wagon
CGM Stg. 2

Default

I know you said that you replaced the radiator cap, but I recall reading that the Mishimoto ones are crap. If you can get an oem one, that may solve your issue. On a side note, is your upper turbo coolant tank full? Is your entire system full of coolant? If you aren't overheating, it either sounds like a pressure buildup (perhaps not enought coolant) or the radiator cap is weak. Good luck.
WRXSD is offline   Reply With Quote
Old 02-07-2012, 05:21 PM   #3
emsmap
Scooby Guru
 
Member#: 159334
Join Date: Sep 2007
Chapter/Region: MAIC
Location: Martinsburg, WV
Vehicle:
02 WRX, 99RS, 96L
AP3,PPG,FMIC, Big turbo

Default

I actually deleted the upper coolant tank since i went with a oil only cooled turbo. The whole system is full. Even in the coolant over flow tank its steaming up a bit. Ill have to get myself a stock cap to see if that helps.
emsmap is online now   Reply With Quote
Old 02-07-2012, 08:50 PM   #4
whtscoobplk
Scooby Newbie
 
Member#: 195400
Join Date: Nov 2008
Chapter/Region: MWSOC
Location: Round Lake, IL
Vehicle:
2004 WRX STi
White

Default

Just had a problem with this happening, i had a cap that was on my car for less than 8 months go bad and actually lost a bit of coolant while driving. Got a new one from NAPA and all is good. Even new parts break sometimes, get a new one and drive on.
whtscoobplk is offline   Reply With Quote
Old 02-08-2012, 05:38 PM   #5
emsmap
Scooby Guru
 
Member#: 159334
Join Date: Sep 2007
Chapter/Region: MAIC
Location: Martinsburg, WV
Vehicle:
02 WRX, 99RS, 96L
AP3,PPG,FMIC, Big turbo

Default

Just replaced with new cap from advance auto parts and still steaming. Next is a compression test i suppose. This sucks
emsmap is online now   Reply With Quote
Old 02-08-2012, 05:41 PM   #6
emsmap
Scooby Guru
 
Member#: 159334
Join Date: Sep 2007
Chapter/Region: MAIC
Location: Martinsburg, WV
Vehicle:
02 WRX, 99RS, 96L
AP3,PPG,FMIC, Big turbo

Default

Just replaced the cap with a new one from advance auto parts and its still steaming. I suppose the next thing to do is a compression test. This sucks
emsmap is online now   Reply With Quote
Old 02-08-2012, 09:20 PM   #7
z
Scooby Specialist
 
Member#: 41762
Join Date: Aug 2003
Chapter/Region: International
Location: House of Pancakes
Vehicle:
04 STi
CT-DE-FL rinse+repeat

Default

Is there a crack in the top of the radiator neck? Get a loaner cooling system pressure tester from pep boys ($130'ish deposit) and pump it up, see what's up.
*Attach to turbo (upper)reservoir.
z is offline   Reply With Quote
Old 02-09-2012, 10:26 AM   #8
emsmap
Scooby Guru
 
Member#: 159334
Join Date: Sep 2007
Chapter/Region: MAIC
Location: Martinsburg, WV
Vehicle:
02 WRX, 99RS, 96L
AP3,PPG,FMIC, Big turbo

Default

Im going to put my reservoir back on today to see if air is getting trapped in the system. Hoping this will make a difference
emsmap is online now   Reply With Quote
Old 03-05-2012, 10:48 PM   #9
marios03wrx
Scooby Specialist
 
Member#: 33593
Join Date: Mar 2003
Chapter/Region: MAIC
Location: Chesapeake, VA
Vehicle:
2002 WrX-ShAgNwAgOn
that is 05 WrX Power'd

Default

Did you ever figure out the problem w/ the rad cap? Having the same issue and trouble shooting now.

Thanx
Mario
marios03wrx is offline   Reply With Quote
Old 03-06-2012, 12:27 PM   #10
emsmap
Scooby Guru
 
Member#: 159334
Join Date: Sep 2007
Chapter/Region: MAIC
Location: Martinsburg, WV
Vehicle:
02 WRX, 99RS, 96L
AP3,PPG,FMIC, Big turbo

Default

Yep! Air was in the system. I installed my upper coolant tank back on and burped the system. All is well
emsmap is online now   Reply With Quote
Old 03-06-2012, 06:09 PM   #11
marios03wrx
Scooby Specialist
 
Member#: 33593
Join Date: Mar 2003
Chapter/Region: MAIC
Location: Chesapeake, VA
Vehicle:
2002 WrX-ShAgNwAgOn
that is 05 WrX Power'd

Default

Cool, thanx for the reply. Back to work i go...


Mario
marios03wrx is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Steam spitting out of exhaust! Help! wrx54 Newbies & FAQs 3 04-01-2011 02:21 PM
HELP. purging air out of radiator DCrally43 Factory 2.0L Turbo Powertrain 4 11-22-2010 01:29 AM
hmmm...smoke/steam coming out of radiator...help? 98subyrezaRS Normally Aspirated Powertrain 11 02-28-2006 03:05 PM
help smoke coming out of hood scoop ? phat pat Factory 2.0L Turbo Powertrain 7 08-04-2004 03:43 PM
Smoke/Steam coming out of vents?? HonduhEater Factory 2.0L Turbo Powertrain 6 07-24-2001 06:03 PM


All times are GMT -4. The time now is 02:22 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.